0

This question already has an answer here:

My laptop has

Intel(R) Core(TM) i5-4200U CPU @ 1.60GHz, 
4G RAM, 
Haswell-ULT Integrated Graphics Controller

Only thing unusual is when I installed Ubuntu 14.04 LTS, I edited grub as

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

I searched about brightness control issues, and they said

'check /sys/class/backlight and do something',

but there was nothing in there. I opened terminal and typed

ls -a /sys/class/backlight

but the output was

. ..

The brightness is too high so my battery is running so fast, but I don't know what i have to do.

marked as duplicate by Mitch Mar 13 '15 at 5:24

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    Hi, why you need the nomodeset parameter in your grub? Do you have any other discrete video card? How about booting without that parameter? (Don't forget to run sudo update-grub) – P.-H. Lin Sep 18 '14 at 8:42
  • Vendor, Model, OS version? Have you tried to dim using the keyboard? All laptops have controls for this, most have a Fn key that needs to be pressed together with something else... – Jan Sep 18 '14 at 9:04
  • I think your graphic driver not installed. type "Additional Drivers" and under Additional Drivers tab select right one graphic driver and click "Apply changes" – αғsнιη Sep 18 '14 at 11:06