3

I used sudo aptitude update and sudo aptitude upgrade to update the packages, and encountered an error when processing the package man-db (with --configure). A few days later, same error occured with libc6:i386. Since there're many packages depends on these two partially installed ones, more and more errors are generated every day.

I tried all methods I can find on the internet, including sudo apt-get -f install and sudo rm /var/cache/debconf/* ; sudo apt-get update , none of them works. I'm not familiar with the Ubuntu system, so I don't know where to find more detailed error message telling what happens.

The system information is

$ cat /proc/version
Linux version 3.13.0-36-generic (buildd@toyol) (gcc version 4.8.2 (Ubuntu 4.8.2-19ubuntu1) ) #63-Ubuntu SMP
$ uname -p -i -r
3.13.0-36-generic x86_64 x86_64
$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.04.1 LTS
Release:        14.04
Codename:       trusty

These're the error messages

$ sudo dpkg --configure -a                                             [99/1979]
Setting up man-db (2.6.7.1-1) ...
dpkg: error processing package man-db (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up libvirtodbc0 (6.1.6+repack-0ubuntu3) ...
dpkg: error processing package libvirtodbc0 (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up cups-bsd (1.7.2-0ubuntu1.2) ...
dpkg: error processing package cups-bsd (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up phonon:amd64 (4:4.7.80-0ubuntu1~ubuntu14.04) ...
dpkg: error processing package phonon:amd64 (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up libc6:i386 (2.19-0ubuntu6.3) ...
dpkg: error processing package libc6:i386 (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up cups (1.7.2-0ubuntu1.2) ...
dpkg: error processing package cups (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of kde-runtime:
 kde-runtime depends on phonon; however:
  Package phonon:amd64 is not configured yet.

dpkg: error processing package kde-runtime (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libdbus-1-3:i386:
 libdbus-1-3:i386 depends on libc6 (>= 2.10); however:
  Package libc6:i386 is not configured yet.

...

If someone could just give advice on finding more detailed error report, that will help. Thx.


Updated(2014.9.18 19:39) Thanks for @Jan 's answer and I got this plenty of new messages:

$ sudo dpkg --configure -D 73777 man-db

D000001: ensure_diversions: new, (re)loading
D000040: checking dependencies of man-db:amd64 (- <none>)
D000400:   checking group ...
D000400:     checking possibility  -> groff-base
D000400:       is installed, ok and found
D000400:     found 3
D000400:   found 3 matched 0 possfixbytrig -
...
D000400:   checking group ...
D000400:     checking possibility  -> dpkg
D000400:       is installed, ok and found
D000400:     found 3
D000400:   found 3 matched 0 possfixbytrig -
D000040: ok 2 msgs >><<
D000040:     checking Breaks
D000400:      checking virtbroken man
D000400:      checking virtbroken man-browser
Setting up man-db (2.6.7.1-1) ...
D020000: trigproc_activate_packageprocessing pkg=man-db:amd64
D000002: fork/exec /var/lib/dpkg/info/man-db.postinst ( configure 2.6.7.1-1 )
dpkg: error processing package man-db (--configure):
 subprocess installed post-installation script returned error exit status 1
D020000: post_script_tasks - ensure_diversions
D000001: ensure_diversions: same, skipping
D020000: post_script_tasks - trig_incorporate
D010000: trigproc_run_deferred
Errors were encountered while processing:
 man-db

and I tried to execute the man-db.postinst script manually, which results in this:

$ sudo sh -x /var/lib/dpkg/info/man-db.postinst configure 2.6.7.1-1
+ set -e
+ . /usr/share/debconf/confmodule
+ [ ! '' ']'
+ PERL_DL_NONLAZY=1 
+ export PERL_DL_NONLAZY
+ [ '' ']'
+ /usr/share/debconf/frontend /var/lib/dpkg/info/man-db.postinst configure 2.6.7.1-1

It seems that the error is due to the /usr/share/debconf/frontend script. But I can't trace more deeply and still don't know what's wrong.

0
Setting up man-db (2.6.7.1-1) ...
dpkg: error processing package man-db (--configure):
 subprocess installed post-installation script returned error exit status 1

This means that the postinst script for the man-db package failed. You can check why using:

dkpg --configure -D 777 man-db

Get help on using -D with dpkg -Dh.

You can also run the postinst script yourself:

sh -x /var/lib/dpkg/info/man-db.postinst configure 2.6.7.1-1

And figure out what's wrong.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.