1

I have a new Acer Aspire V3-572 with a pre-installed Windows 8.1. I tried to install Ubuntu 14.04 LTS alongside Windows in UEFI boot mode, however, the systems gives me the following message "System doesn't have a usb boot option" whenever I try to boot from the usb. I modified the Boot priority options to detect the USBs first, but nothing has changed. Hence, I had to switch to legacy mode to install Ubunutu, and it worked perfectly. The problem now is that Windows does not appear in the grub menu. I tried to use boot-repair and it advised me to switch to UEFI boot mode before proceeding with the "recommended repair". I did as advised, but now, every time I boot, it directly boots into windows. Hence, every time I need to use one of the OSs, I need to switch back and forth between Legacy and UEFI mode. I want to switch the installed Ubuntu to UEFI, but I can't due to the error message mentioned earlier. Any help with this problem would be appreciated. I have searched all the internet, and I couldn't get a perfect solution for the problem.

Thank you in advance.

0

I think this is because you have to add the usb device to the list of uefi boot drives. Search over the web for guides on how to do that. Once you can start a live distro from your usb drive in Uefi mode, you can use boot-repair in it and solves your problems. This works for me ;)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.