1

I'll hope that you can help me!!

I've tried to execute linaxepad (application/x-executable), extracting from "linaxepad.tar.gz" file.

But nothing happens (Ubuntu doesn't show anything) and if I try from terminal, Ubuntu shows this:

http://imageshack.com/a/img903/9783/zP7sbC.jpg

http://imageshack.com/a/img911/3939/E2IUny.jpg

My Ubuntu version is 14.04 LTS

I don't know if the .tar.gz file will be compatible.

The download section (Picaxe webpage) shows this:

"LinAXEpad for Linux (v1.5.0 for x386 with GTK2.8+)"

1

First of all, when you run from terminal, the command is case sensitive. So run LinAXEpad with capital L.

LinAXEPad is not starting because some dependencies are missing. Here are the libraries needed (found using ldd):

    ldd LinAXEpad
linux-gate.so.1 =>  (0xf777f000)
libgtk-x11-2.0.so.0 => not found
libgdk-x11-2.0.so.0 => not found
libgmodule-2.0.so.0 => not found
libglib-2.0.so.0 => not found
libgthread-2.0.so.0 => not found
libgobject-2.0.so.0 => not found
libgdk_pixbuf-2.0.so.0 => not found
libpango-1.0.so.0 => not found
libpangocairo-1.0.so.0 => not found
libpangoft2-1.0.so.0 => not found
libpthread.so.0 => /lib/i386-linux-gnu/libpthread.so.0 (0xf7740000)
libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xf773b000)
libXi.so.6 => /usr/lib/i386-linux-gnu/libXi.so.6 (0xf7729000)
libXext.so.6 => /usr/lib/i386-linux-gnu/libXext.so.6 (0xf7716000)
libX11.so.6 => /usr/lib/i386-linux-gnu/libX11.so.6 (0xf75e2000)
libstdc++.so.6 => not found
libm.so.6 => /lib/i386-linux-gnu/libm.so.6 (0xf759c000)
libgcc_s.so.1 => /lib/i386-linux-gnu/libgcc_s.so.1 (0xf757e000)
libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xf73ce000)
/lib/ld-linux.so.2 (0xf7780000)
libcairo.so.2 => not found
libxcb.so.1 => /usr/lib/i386-linux-gnu/libxcb.so.1 (0xf73ac000)
libXau.so.6 => /usr/lib/i386-linux-gnu/libXau.so.6 (0xf73a8000)
libXdmcp.so.6 => /usr/lib/i386-linux-gnu/libXdmcp.so.6 (0xf73a0000)

It requires GTK 2. Note that if you have a 64 bit Ubuntu, 32 bit versions of those libraries will be required.

Try to install:

sudo apt-get install libgtk2.0-0:i386 libcairo2:i386 libpango1.0-0:i386 libgdk-pixbuf2.0-0:i386 libstdc++6:i386
  • Ok. With your code, I got this: "./LinAXEpad: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory" – Falconunknown Sep 16 '14 at 18:48
  • @Falconunknown sudo apt-get install libstdc++6:i386 – Cornelius Sep 16 '14 at 18:49
  • Finally I could open LinAXEpad in Ubuntu. But terminal shows this (Don't know if that's right): Gtk-Message: Failed to load module "overlay-scrollbar" Gtk-Message: Failed to load module "unity-gtk-module" (LinAXEpad:8674): Gtk-WARNING **: Imposible encontrar el motor de temas en la ruta al _modulo: «murrine», Gtk-Message: Failed to load module "canberra-gtk-module" – Falconunknown Sep 16 '14 at 18:56
  • @Falconunknown that's ok. It's just telling you that the theme wasn't correctly loaded, bu that doesn't affect the functionality of the app. – Cornelius Sep 16 '14 at 18:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.