1

I'm fairly new to Ubuntu. I'm using a mouse with two extra thumb buttons and I figured it would be handy to use them for volume control.

After googling around a bit I ended here: Configuring mouse buttons to switch between apps? Decided to try it out (first with the example for switching apps to see if that worked).

So I wrote "xdotool key alt+Tab" b:9 + Release in a file called .xbindkeysrc

I ran xbindkeys -v -n in the terminal, which seemed to work, however the mouse button did nothing. Upon closing and running again, I now got a warning too stating that there is some other program controlling the mouse buttons.

Upon using the command xev, which normally shows the number of the mouse button upon clicking in a white square, the ninth button didn't show 'button 9', instead it gave 'mode NotifyGrab, detail NotifyVirtual'

Any advice on how I can make it work the way I need to? Thanks a lot!

  • 1
    One useful trick when playing with keyboard and mouse remappings is that if you unplug the USB device and replug it again the settings are reset and you can start over. – BobDoolittle Sep 16 '14 at 18:10
  • It didn't work, stays as before. – Knoerifast Sep 16 '14 at 19:16

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.