2

I am behind a transparent proxy (squid) and whenever I try to add an account e.g: facebook, google, etc., this is what appears. This does not happen when I connect to the net directly.

Any suggestions or workarounds?

Blank Page

0

All parts of this answer have been re-worded from Fossfreedom's Answer available here. You should read it, as it gives picture examples and gives a solely command-line method as well.

Instead of running a proxy by using the GUI settings menu, you can use DConf.

First off, install dconf-tools and run dconf-editor in a console. It should open a GUI.

Under org.gnome.system.proxy, set the proxy mode to manual. Check use-same-proxy.

In http and https, set your according proxy settings.

Relog/reboot and it should be solved.

| improve this answer | |
  • Exactly as what muru said above; I'm running a transparent proxy and therefore do not need to set manual proxies. I have tried this solution as well, without any results. – Rey Leonard Amorato Sep 21 '14 at 16:04
0

Transparent proxies are for unsecured (e.g. HTTP) connections only.

Adding accounts is done with HTTPS.

HTTPS proxying can only be done explicitly, not transparently. Or, with great effort, you can set up a near-"transparent" HTTPS proxy by emulating a man-in-the-middle attack. (Search the web for "SSL Bump")

You'll need to either set up an SSL bumping proxy, or manually specify the HTTPS (not necessarily HTTP) proxy as described in the other answers relating to non-transparent proxies.

| improve this answer | |
  • I do have ssl-bump option set in squid, compiled with --enable-ssl and --enable-ssl-crtd flag. I can't determine if the problem is from squid or online accounts. – Rey Leonard Amorato Sep 25 '14 at 3:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.