1

Until now my keyboard mapping in Kubuntu 14.04 has worked seamlessly in the guest OS of Windows 7, which I run in VirtualBox. But after the upgrade to VirtualBox version 4.3.16 r95972 the swapping of Ctrl & Caps Lock is not respected. Any ideas for fixing this - or is it a known bug in the new VirtualBox version?

Thanks!

-HStovring

Update: I found the AutoHotKey program, which allows you to do the swapping inside Windows (plus a bunch of other stuff). After installing the program I placed a simple text file in my C:\Users\username\ directory with this content:

+Capslock::Capslock ; make shift+Caps-Lock the Caps Lock toggle Capslock::Control ; make Caps Lock the control button

1
1

I had the same problem with the same version of Virtual Box. I was able to work around the problem by running ctrl2cap.exe in Windows from the Sysinternals tool suite.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.