I am having Acer Aspire 5742Z Model-PEW71 laptop with NVIDIA GeForce GT 540M.I have installed Ubuntu 14.04 x64 with dual boot with Windows 7. After installation it was working good. I installed Java and eclipse. Updated display driver from setting updates. Next day when I started my laptop after selecting Ubuntu on startup screen it lands to ubuntu login screen, here I am getting issue, some times it allows to enter password, some times it shows blank screen, some time its getting hang on login screen, some time I am able to pass through login but on next it shows error message by saying send report problem, after pressing send report or cancel button the error message disappear, it shows full wallpaper with mouse courser but nothing else.

How can I solve this without re-installing ubuntu? I tried running with failsafe mode but still behaving same.

Sorry for typing mistakes and bad English.


You should try installing the NVIDIA proprietary drivers. If you can't download it via that computer, download it to a USB via another computer and then put it on your PC.

I've found that manual installs work best for installing nvidia drivers, so go to here and download the latest drivers. By default, it'll most likely go into /Downloads, but if not, just know where it is. Then, you'll want to press

ctrl + alt +F1-F6 (each is a different login)

And then sign in to your account. Then, you'll want to use

sudo stop lightdm (or sudo service lightdm stop)

This shuts down the things that are using the GUI, so they can be updated.

Then run

chmod +x ~/* Folder that said driver is located in * / * Driver *

For example,

chmod +x ~/Downloads/NVIDIA-Linux-x86_64-343.13.run

Make SURE that you have the entire name of the driver, otherwise this will not work! Caps do matter!

What you just did was make the file executable. Next, you'll want to run the following command, changed of course like the example above to fit your directories/driver versions.

sudo sh ~/Downloads/NVIDIA-Linux-x86_64-343.13.run

For me, tabbing the rest of the NVIDIA-Linux-x86_64-343.13.run file does not work for me, but it is CRUCIAL THAT YOU DO THIS. If nothing happens after you run the second command, check your caps and spelling to make sure they are right. You have to go through the program using the keyboard to correctly install it. For me it will tell me that something went wrong right on the bat, just keep going and see if it still works. If it asks you to install 32 bit libraries, do so. Some programs (like steam games) will not run unless you have these installed.

After all of the above has been done, one final command must be completed, or of course you could reboot.

sudo start lightdm (or sudo service lightdm start)

Then, you'll do

ctrl + alt+ F7-F9ish (F7 is usually default, some people have different F keys though)

This should have worked for most people, if not keep looking, there's always a fix. If anyone knows something about getting virtual 7.1 audio to work, please message me somehow. Thanks. Hope I helped someone.

Edit:I've also heard x-swat repositories work better at times. Not sure about that, but worth a try.

(Pro tip, whenever Nvidia related stuff goes wrong, watch this.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.