10

I upgraded my Ubuntu from 12.04 to 14.04 and hotkeys for switching workspaces (Ctrl + Alt + arrow keys) are not working anymore.

I checked in System Settings > Keyboard > Shortcuts to make sure that they're assigned and they are, but why they are not working? How can I fix this problem?

13

I found the solution myself. It seems that I needed to enable Desktop Wall plugin in Compiz; just apt-get install compizconfig-settings-manager, run ccsm and search for "wall" to find the option.

  • 1
    This answer provides additional details which eventually helped me resolve this. – klenwell Aug 23 '15 at 23:59
  • how do you do that exactly can you please share details? – Jas Nov 9 '15 at 6:25
  • same happened to me in ubuntu 16.04 and this solution solved it. thanks – psychok7 Jul 1 '17 at 20:29
2

This has broken for me a couple times now in Ubuntu; most recently after going from 12.04LTS to 14.04LTS (in place upgrade).

  • System Settings... (gear at top of screen)
  • Appearance
  • Behavior Tab
  • Check box for Enable workspaces

Screen grab of configuration setting for workspaces:

image

0

Run these two commands:

sudo apt-get install ubuntu-desktop
sudo apt-get install unity

Reboot your system

And after than try Ctrl + Alt + arrow keys. You will able to switch between workspaces.

  • unfortunately doesn't work for me :( I'm able to switch between 1 and 2 while cannot go to 3 and 4 via 1 and 2. In other words I'm able to switch horizontal between 1 and 2, 3 and 4 while I'm not able to switch between 1 and 3, 2 and 4 :( – Hesam Oct 2 '15 at 23:56

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.