0

when I give this command

apt-get install build-essential autoconf automake libxmu-dev

it gives the following error

E: Package 'build-essential' has no installation candidate
E: Package 'autoconf' has no installation candidate
E: Package 'automake' has no installation candidate
E: Unable to locate package libxmu-dev
  • 1
    Include in your question the output of these four commands: 1) lsb_release -sr, 2) sudo apt-get update, 3) apt-cache policy build-essential, 4) grep -r ^deb /etc/apt/sources.list*. Please edit your question to do so and please use proper formatting. – gertvdijk Sep 15 '14 at 13:22
1

Try to first enable the main repository:

sudo add-apt-repository "deb http://archive.ubuntu.com/ubuntu $(lsb_release -sc) main"
sudo apt-get update

And finally:

sudo apt-get install build-essential autoconf automake libxmu-dev
  • -1. Just to install build-essential and GNU autotools you really don't need to enable all these repositories. – gertvdijk Sep 15 '14 at 13:46
  • thank you sir a bundle of thanx for your kind information – shabeer Sep 15 '14 at 13:56
  • @gertvdijk: Thanks, I've updated my answer as all those packages seem to be in main – Sylvain Pineau Sep 15 '14 at 13:56
  • it works fine now – shabeer Sep 15 '14 at 13:56
  • 1
    Shouldn't the main repository be enabled by default? – David Foerster Apr 11 '18 at 10:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.