1

I'm trying to install Ubuntu 14.04.1 (ubuntu-14.04.1-desktop-amd64.iso), but always get error message same to one from this question (and same stage of installation): https://askubuntu.com/questions/492430/when-installing-ubuntu-i-get-error-message-and-cannot-install-it

I have Windows 7 installed & some ntfs partitions (Music & Video & etc) & some old ext4 partitions (I always mount /home as a separate partition and have enough space to not remove previous ones ... just in case). I want to keep both OS (Win & Ubuntu) and have boot menu. So, I choose "Something else" when asked for disk usage by new system. I have ordinary 1.5TB disk without any RAIDs or etc. I try to create new partitions of 38GB and 50GB for "/" and "/home" respectively and select to format them as ext4 ("/" partition is physically third on the disk - Windows 7 100GB and its loader 100MB partition are placed before, "/home" is fifth)

And every time I finish these operations - it fails on the next screen (I don't think selecting city is a reason, because sometimes I go to the next screen with keyboard layout and only then popup appears). It looks like some async operation on partition changing fails. After closing popup it returns me to selecting disk usage by new system. As a result I always get two new partitions of "unknown type". I remove them from Windows and retry - looks like infinite loop :(

Tried to boot from DVD burned on Windows. Used checking image - says OK

I tried both direct and from-live-CD types of installation - same issue

Could anyone help me? Can provide more details, if it is required

P.S. I tried to format partitions as ext4 directly from live-CD using gparted and it says "Libparted Bug Found!" "Failed to add partition 3 (No such device or address)". It fails to format logical partition in extended area, which I try to use as "/home". Probably that's the cause

  • Please add the output of sudo gdisk /dev/sdX where X is the drive in question. Likely sda. Thank you. – Elder Geek Nov 27 '14 at 14:24
2

Found workaround: At first, create ext3 instead of ext4 partitions by GParted. Than format ext3 as ext4. Do not use formatting at all during installation. Works!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.