I'm using lubuntu, but still think it's very similar to ubuntu. I need to install exfat-nofuse as my NAS has exfat format.

I followed these instructions on this post: https://askubuntu.com/a/400946/313828

Everything was fine until the last code:

sudo modprobe exfat_fs

All I get is this message: modprobe: FATAL: Module exfat_fs not found. Same result if I use exfat without '_fs'

  • Are you running Ubuntu 13.10? Sep 15, 2014 at 2:03
  • The above command works on Lubuntu 14.04.
    – Mitch
    Sep 15, 2014 at 9:06

2 Answers 2


Try this:

sudo -i
apt-get update
apt-get install exfat-utils exfat-fuse
  • This will only work if the poster is using Ubuntu 14.04 or above, and is quite well answered by askubuntu.com/questions/451364/… Sep 15, 2014 at 2:06
  • Sorry if I'm really late with this. I started only now to reuse lubuntu. Thank you kyodake, your suggestion worked. Now I can access to exFat HDDs. I can't still manage to load it to the kernel (I get the same error). What exactly loading to the kernel should do? Back in September '14 I was using Lubuntu 14.04, now I did a clean install and I'm using Lubuntu 14.10.
    – ziovelvet
    Feb 22, 2015 at 15:30

For exfat-nofuse module install using dkms:

sudo -i
cd /usr/src
git clone https://github.com/dorimanx/exfat-nofuse
mv exfat-nofuse exfat-nofuse-1.2.9
echo 'PACKAGE_NAME="exfat-nofuse"
MAKE[0]="CONFIG_EXFAT_FS=m make KDIR=$kernel_source_dir"
' > ./dkms.conf
dkms add exfat-nofuse/1.2.9
dkms build exfat-nofuse/1.2.9
dkms install exfat-nofuse/1.2.9
modprobe exfat && dmesg | tail -1

If successful output should be like exFAT: Version 1.2.9

Based on this post: http://www.lushnikov.net/2015/02/25/ubuntu-14-04-%D0%B8-exfat-nofuse/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.