1

I've set up my own apt repository to serve some .deb packages over LAN and I've set up my puppet configuration to install these packages.

If I use apt-get install to download the package it works fine, but when I run my puppet manifest, it throws this error when it tries to install:

Error: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install cuda-repo-l4t-r19.2' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
The following NEW packages will be installed:
  cuda-repo-l4t-r19.2
0 upgraded, 1 newly installed, 0 to remove and 7 not upgraded.
Need to get 0 B/424 MB of archives.
After this operation, 426 MB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
  cuda-repo-l4t-r19.2
E: There are problems and -y was used without --force-yes

Error: /Stage[main]/Main/Package[cuda-repo-l4t-r19.2]/ensure: change from absent to present failed: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install cuda-repo-l4t-r19.2' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
The following NEW packages will be installed:
  cuda-repo-l4t-r19.2
0 upgraded, 1 newly installed, 0 to remove and 7 not upgraded.
Need to get 0 B/424 MB of archives.
After this operation, 426 MB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
  cuda-repo-l4t-r19.2
E: There are problems and -y was used without --force-yes

I'm not sure exactly where the problem is; puppet? My repository? Something else?

1

Looks like it was because my repository wasn't authenticated. I got around this by adding allowing apt to download from unauthenticated repositories, and did this by creating the following file using puppet:

  file { "/etc/apt/apt.conf.d/99auth":       
    owner     => root,
    group     => root,
    content   => "APT::Get::AllowUnauthenticated yes;",
    mode      => 644;
  }

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.