First time posting here for help.

So Friday night I was playing around with GParted and accidentally deleted several partitions. One of the was an unnamed. After doing this, I restarted and I was greeted with the "Reboot and select proper boot device".

Knowing I had screwed up, I looked up the problem and arrived to the conclusion that I had nuked the EFI partition that basically held the boot loader. One of the proposed ways to fix it was to use the Windows Boot Repair option for an installation disk. This morning I tried that option and it worked! I can now boot into Windows.

After doing that, I booted into a live CD and I tried to reinstall GRUB2 via the Boot Repair guide over at https://help.ubuntu.com/community/Boot-Repair This is where my problem begins. I can't seem to get GRUB to show up as my default bootloader. Here is the pastebin log from that: http://paste.ubuntu.com/8345872/

I followed another guide that said I needed to point at the bootloader from within Windows by using

bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi

But even this doesn't seem to work as I am greeted with the following:

C:\WINDOWS\system32>bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi
The parameter is incorrect.

Running bcdedit by itself returns the following:


Windows Boot Manager
identifier              {bootmgr}
path                    \EFI\Microsoft\Boot\bootmgfw.efi
description             Windows Boot Manager
locale                  en-US
inherit                 {globalsettings}
integrityservices       Enable
default                 {current}
resumeobject            {cbbe29da-23e7-11e4-9d02-bbb0e4fcb58b}
displayorder            {current}
toolsdisplayorder       {memdiag}
timeout                 30

Windows Boot Loader
identifier              {current}
device                  partition=C:
path                    \WINDOWS\system32\winload.efi
description             Windows 8.1
locale                  en-US
inherit                 {bootloadersettings}
recoverysequence        {cbbe29d8-23e7-11e4-9d02-bbb0e4fcb58b}
integrityservices       Enable
recoveryenabled         Yes
isolatedcontext         Yes
allowedinmemorysettings 0x15000075
osdevice                partition=C:
systemroot              \WINDOWS
resumeobject            {cbbe29da-23e7-11e4-9d02-bbb0e4fcb58b}
nx                      OptIn
bootmenupolicy          Standard
The parameter is incorrect.


I am at a loss of how I could get around this issue, but more importantly, how I can get GRUB2 as my bootloader so I can get into Ubuntu Partition. Any help is appreciated. Thank you for your time.


Running the command efibootmgr -v yields me the following,

BootCurrent: 0005
Timeout: 1 seconds
BootOrder: 0004,2003,2001,2002
Boot0000* Windows Boot Manager    HD(4,96800,32000,d5769c5b-3c38-11e4-9237-c832b0e56206)File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}...\................
Boot0001* UEFI: Network Card     ACPI(a0341d0,0)PCI(1c,3)PCI(0,0)MAC(202564958e96,0)IPv4(<->,0, 0..BO
Boot0002* UEFI: Network Card     ACPI(a0341d0,0)PCI(1c,3)PCI(0,0)MAC(202564958e96,0)030d3c000000000000000000000000000000000000000000000000000000000000000000000000000000004000000000000000000000000000000000..BO
Boot0003* UEFI: M4-CT256M4SSD2    ACPI(a0341d0,0)PCI(1f,2)03120a000400ffff0000HD(1,96800,32000,d5769c5b-3c38-11e4-9237-c832b0e56206)..BO
Boot0004* ubuntu    HD(1,96800,32000,d5769c5b-3c38-11e4-9237-c832b0e56206)File(\EFI\ubuntu\grubx64.efi)
Boot0005* UEFI: TSSTcorp CDDVDW SU-208FB    ACPI(a0341d0,0)PCI(1f,2)03120a000500ffff0000CD-ROM(1,76991,1240)..BO
Boot2001* EFI USB Device    RC
Boot2002* EFI DVD/CDROM    RC
Boot2003* EFI Network    RC

FDisk returns:

WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.

Disk /dev/sda: 256.1 GB, 256060514304 bytes
255 heads, 63 sectors/track, 31130 cylinders, total 500118192 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xd4a6f69c

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1   500118191   250059095+  ee  GPT

I ran GDisk and it returned me this:

GPT fdisk (gdisk) version 0.8.8

Partition table scan:
  MBR: protective
  BSD: not present
  APM: not present
  GPT: present

Found valid GPT with protective MBR; using GPT.
Disk /dev/sda: 500118192 sectors, 238.5 GiB
Logical sector size: 512 bytes
Disk identifier (GUID): 5657A54D-73E9-4B33-8700-A8E287822B16
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 500118158
Partitions will be aligned on 2048-sector boundaries
Total free space is 879213 sectors (429.3 MiB)

Number  Start (sector)    End (sector)  Size       Code  Name
   1          616448          821247   100.0 MiB   EF00  
   2         1083392       395257855   188.0 GiB   0700  Basic data partition
   3       395257856       500117503   50.0 GiB    8300  

The third partition is where Ubuntu is installed. The 100MB partition is the EFI partition created by the Windows Start-Up Repair and the second one is the Windows 8.1 partition.

  • You should not try to fix EFI by using BCDEdit. It's not going to work. Your output already shows that Ubuntu is the first choice: BootOrder: 0004,2003,2001,2002 Which brand is your laptop? Those from HP are very mean with the bootloader and always overwrite the Windows one, while others are easier to deal with. Sep 14, 2014 at 22:27
  • @AndreaLazzarotto It is a Toshiba Satellite S55. This problem just arose. Before I deleted the previous EFI partition, I was able to dual-boot with no problem.
    – subseven
    Sep 14, 2014 at 22:31

2 Answers 2


Test this:

Boot into a live Dvd/Usb Ubuntu 64 bit

Open a terminal.

Run it:

sudo -i
mount /dev/sda3 /mnt
mount /dev/sda1 /mnt/boot/efi
mount --bind /dev /mnt/dev 
mount --bind /dev/pts /mnt/dev/pts
mount --bind /proc /mnt/proc
mount --bind /sys /mnt/sys
modprobe efivars
chroot /mnt
apt-get install --reinstall grub-efi-amd64
umount /mnt/boot/efi
umount /mnt
  • This solution didn't work for me. But thank you.
    – subseven
    Sep 14, 2014 at 22:58

It should be possible to repair GRUB, however I suggest to try rEFInd because it's very easy to use.

rEFInd automatically finds operating systems on internal and external drives, and should not need configuration at all (but it can be configured for particular circumstances).

It can be installed from Windows and also from the live environment.

Installing from the live environment

You should mount the efi partition as /boot/efi. To do this, run:

sudo mkdir -p /boot/efi
sudo mount /dev/sdXN /boot/efi

You need to place the right device letter instead of X and the right partition number instead of N. After that, you can add a PPA and download a DEB file which will automatically copy rEFInd in the right place during the installation.

sudo apt-add-repository ppa:rodsmith/refind
sudo apt-get update
apt-get install refind

After rebooting, you should be able to select which OS you want to run, without any further configuration.

Installing from Windows

Installing manually from Windows takes a bit longer. The step-by-step process is described here.

  • Unfortunately, it was not able to resolve the issue. I boot straight into Windows 8. No additional boot manager. I'm considering just reinstalling everything because it seems this issue is going to be quite the hassle to fix.
    – subseven
    Sep 14, 2014 at 23:08
  • Did you check the boot sequence in the "BIOS"? (Well I'm not sure I should call it BIOS since it's using EFI, but I hope it's clear what I mean) Sep 14, 2014 at 23:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .