3

My Wi-Fi driver, I think, is not functioning properly on my Lenovo Z50-70 using a Ubuntu 14.04 OS.

After connecting to a wireless network it works for a brief period of time, then, although it shows a stable connection, I can't access any website whatsoever.

I tried the Wi-Fi on Windows 8.1 and it worked perfectly.

Any ideas guys?

  • Please run the script that is in the accepted answer in the link below so we may see the information needed to help diagnose the issue. <askubuntu.com/questions/425155/…> – Wild Man Sep 14 '14 at 19:35
  • I read in other forums that there are no current Ubuntu WiFi drivers for our Realtek card built in on the Lenovo Z50-70. I have been dealing with the same problem for the last week, also running Ubuntu 14.04 on a z50-70 Lenovo laptop and go to the conclusion it will only run properly when running Ubuntu 13.X (or reset laptop by every time the connection fails). – Krisiun Lord Sep 15 '14 at 22:45
  • Hello Wild Man. I have run the script from the link you provided. It provides an output but I am unaware of the information I should gather from it. Could you please provide more hints? I mean, I can read the information from this output file but I do not know what to do with it next. Best regards. – Remus-Andrei Pãun Sep 22 '14 at 19:23
  • I have same issue. How did fix this ? – Venkat Kotra Oct 5 '14 at 11:54
2

I was able to fix this issue after lot of research and facing kernel panic issues. Here is how I fixed it.

Note This can be used for installing any realtek wireless driver

lspci | grep Network

Note: If in this process you get kernel panic issue. DONT PANIC Solution for it is at the end. You dont need to re-install Ubuntu.

  1. Upgrade linux kernel

  2. Install following

    sudo apt-get install git build-essential linux-headers-$(uname -r) linux-headers-generic
    
    git clone https://github.com/lwfinger/rtlwifi_new
    cd rtlwifi_new
    make clean
    make
    
    sudo make install
    
    sudo depmod -a
    
    sudo modprobe rtl8723be
    
    echo "options rtl8723be fwlps=0" | sudo tee /etc/modprobe.d/rtl8723be.conf
    
  3. Reboot

Sources:

Kernel panic If you run into kernel panic issue where the system does not reboot

  1. Reboot into recovery mode
  2. Log in with root
  3. Mount file system in read write mode

    mount -o rw,remount /
    
  4. Add the driver that you just added to the blacklist

    vim /etc/modprobe/blacklist.conf
    

    Add line blacklist rtl8723be

  5. Reboot

protected by Community Aug 20 '15 at 18:41

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.