0

When I hit Ctrl+F and type any uppercase letter (using the Shift key) in the search dialog, the dialog closes and the letters appears in the document instead. I don't remember changing any shortcut configuration. What could be causing this?

11
  • Have you tried restarting or logging back in? It might be a temp glitch.
    – user271219
    Commented Sep 22, 2014 at 20:13
  • silly questions, but does this happen as well if you choose "search" from the menu? and another question: does it happen as well if you search with Control_R+F? Commented Sep 22, 2014 at 21:17
  • 1
    Two more: did you ever use xdotools to set up key combinations, or made special key combinations in System preferences > Keyboard > shortcuts? (although you alredy mentioned you didn't) Commented Sep 22, 2014 at 21:54
  • 2
    @JacobVlijm in Keyboard shorcuts, I added Shift+Shift R in Typing as "Switch to next source". That was indeed the cause. Do you have any idea why this shortcut causes the behavior I described? I have been using this combination since Ubuntu 08.10 or so.
    – brabec
    Commented Sep 29, 2014 at 19:49
  • 1
    Actually I was hoping to find a key combination that would somehow cause <Esc>, which "officially" causes the search box to close, but I guess this is one of those weird coincidences that internally causes unpredicted behaviour. Commented Sep 29, 2014 at 20:08

1 Answer 1

2
+50

In gedit, there are several ways to close the search box. According to this site, it closes when you press either Esc or Enter (of course it is probably in the help file as well). The search is to find any shortcuts you might have set in the past that could work as one of those keys.

What I would try to find directions:

  • does this happen as well if you choose "search" from the menu?
  • does it happen as well if you search with Control_R+F?
  • did you ever use xdotools to set up key combinations, or made special key combinations in System Settings > Keyboard > Shortcuts?

Try and see if any of these can give you a clue, look into System Settings > Keyboard > Shortcuts > Custom Shortcuts, disable all and see if the problem is fixed. Activate them one by one to see which one gives the error.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .