1

Question 1: I'm the administrator of my Lubuntu system. I only have one "Desktop User" account for all kids. But when ever the Desktop User tries to access or open the "Data"[NTFS partition](Drives where movies, pics, songs and other files are stored) it asks for the Administrator's password. I created the user account for all my other family members and I don't want to tell them my password.

So is it possible to allow them to access the "Data" NTFS partition without asking Administrator's password ? it says "Authentication is required to Mount (/dev/sdc7)"

Question 2: i'm on lubuntu 14.4.0 (by the way how to check my installed lubuntu version?) and will it update from SOFTWARES & UPDATES it self or i'll always need to CLEAN FORMAT INSTALL a never version everytime?

NOTE: please provide a screen tutorial how to fix the "Question 1" because lubuntu is my 1st linux ever. and I'm a novice user. just installed yesterday.

SOLVED Question 1: in DISK App on NTFS Partition. i Turned On Auto Mount and then added "users" in the Text bar displaying codes. And it works now :-)

  • 1
    If you have multiple questions, please post them separately. You can edit the question. – Volker Siegel Sep 14 '14 at 3:45
  • Don't add solved in your question, accept the answer that solved your question instead. – Alvar Sep 14 '14 at 19:16
  • @Alvar won't adding [SOLVED] make it easier for people to find the solution who use Search option within website or on google.com? landing more hits to the question and answer directly all together? – DevilMind Sep 15 '14 at 19:46
  • not on this site, a solved question is marked in green in the search list on this site. – Alvar Sep 16 '14 at 4:27
1

Specify the users mount option in its /etc/fstab entry. That lets regular users mount and unmount the partition without a password.

Reference

  • can you show photo screen shot of this how to do it?? – DevilMind Sep 14 '14 at 15:27
  • Look for this: /dev/sda2 /media/mountpoint ntfs-3g noauto,users,uid=bill,gid=users,file_mode=0644,rw 0 0 Replace /dev/sda2 with your partition and /media/mountpoint with where you want to mount it. Replace uid=bill with your desired owner of the mountpoint. – headkase Sep 14 '14 at 17:06
1

Give your user account an entry in /etc/sudoers to use mount. Or you could always mount ntfs partition at boot time by adding a line to the end of /etc/fstab. First create a directory in /mnt and alter permissions and ownership using chmod and chown. Add the line to fstab, reboot and test.

The fstab method will be best.

As root or via sudo:

  1. Create a directory to mount sdc7 to.
  2. Alter new directory's permissions and ownership.
  3. Mount sdc7 to new directory.
  4. Using su check that users can access the file system.
  5. Enter command ls -l /dev/disk/by-uuid, note the UUID of sdc7.
  6. Open /etc/fstab in a text editor. Each line is a record, fields separated by tabs. Add new line reading something like:

    UUID={uuid@5} {path of @1} ntfs defaults 0 3
    
  7. Save and reboot your system, if the boot sequence reports unable to mount... the UUID is probably wrong.

(If you're new, commands apropos and man will help.)

  • 1
    You might want to add the users mount option here... – Thomas Ward Sep 14 '14 at 15:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.