4

I'm new to this whole Linux thing, and although I have been able to figure out how to set up Ubuntu thus far, there is one issue that bugs me.

Whenever I attempt to restart the computer, it freezes at the purple screen with the dots and all that. Just, completely stops. I have had to remove the battery from my computer to force it to shut down.

Strangely enough, there is no issue when I use the normal shutdown option. Only the reboot option. How can I fix this issue?

6

Alright, so after a bit of fiddling around, I think I've found a solution. The problem, from my understanding, is that the kernel might not know what to do when it is asked to reboot on certain hardware. We can fix this.

Right, so first, get yourself grub customizer. Once you have it, open it, go to general settings, and under kernel parameters there is a line that should say quiet splash.

Now, once you have found that line, you have to edit it so it says quiet splash reboot=pci. After you have done that, you have to go to the terminal and update the grub file by writing sudo update-grub. Once that is done, shut down your pc and start it up again.

And you're done! Note that the reboot process is a little slow.

But wait, what if it doesn't work? Never fear. You might have to change the "=pci" to something else. Below is a list of commands you can try. However, from my understanding, 90% of all the issues can be fixed with either "=pci", "=bios", or "=acpi".

warm =  Don’t set the cold reboot flag

cold = Set the cold reboot flag

bios = Reboot by jumping through the BIOS (only for X86_32)

smp = Reboot by executing reset on BSP or other CPU (only for X86_32)

triple = Force a triple fault (init)

kbd = Use the keyboard controller. cold reset (default)

acpi = Use the RESET_REG in the FADT

efi = Use efi reset_system runtime service

pci = Use the so-called “PCI reset register”, CF9

force = Avoid anything that could hang.

List was copied from this site

Hopefully that can help someone.

  • Your answer withacpi worked for me after trying a bunch of other answers and commands. – Mark Aug 2 '15 at 14:57
  • 1
    I wish Ubuntu would just try all of them for me and remember which one worked.... – XiaoChuan Yu Aug 29 '15 at 18:17
2

You can pass boot parameters by editing GRUB's configuration file directly:

sudo -H gedit /etc/default/grub

Then change to above list. This worked for me.

GRUB_CMDLINE_LINUX_DEFAULT="reboot=pci"
GRUB_CMDLINE_LINUX="reboot=pci"
0

I've seen this bug a couple of times and as of yet have seen no fix other than a reinstall to fix corrupted packages sometimes. I know I don't seem to be helping much but basically the solution I suggest is to either live with shutting down and turning on and if you need to reboot and don't mind the effects a force shutdown sometimes has you can use alt+sysrq+b to do a force restart that basically crashes all processes and the computer restarts immediately.

  • 1
    Well, that blows. I guess I will just wait for an update and in the mean time just shut down completely whenever I have to. – Muggi Sep 14 '14 at 9:32

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.