3

This question already has an answer here:

I'm fairly new to Ubuntu and one issue that I have with it is that there is no simple, easy way (as far as I know and please tell me if you have found a better way) to set up fool-proof parental controls. What I did with Ubuntu is to disable the guest account, password protect the admin account, and install ProCon Latte Content Filter on all the basic user’s firefox web browsers and configure them accordingly.

I got a new computer and decided to put Lubuntu 14.04 on it. Works great. Only issue so far: I cannot figure out how to disable the guest session. I searched around, but all the documentation tells me to sudo edit a file that doesn’t exist in Lubuntu 14.04. What does exist are these:

advanced@Dimension5150:/usr/lib/lightdm$ ls

guest-session-auto.sh  lightdm-greeter-session  lightdm-guest-session

advanced@Dimension5150:/etc/lightdm$ ls

lightdm.conf.d            lightdm-gtk-greeter-ubuntu.conf
lightdm-gtk-greeter.conf  users.conf

So, could someone please tell me how to disable the guest session, or remove internet access (networking) from it?

marked as duplicate by karel, Eliah Kagan, muru, Eric Carvalho, Sylvain Pineau Oct 2 '14 at 6:55

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

4

Please see this page in the Ubuntu Desktop Guide. That solution works fine on Lubuntu too.

The instructions:

If you prefer to not allow guest access to your computer, you can disable the Guest Session feature. To do so, press Ctrl+Alt+T to open a terminal window, and then run this command (it's one long command, even if it may be shown wrapped on the screen - copy and paste to get it right):

sudo sh -c 'printf "[SeatDefaults]\nallow-guest=false\n" >/usr/share/lightdm/lightdm.conf.d/50-no-guest.conf'

The command creates a small configuration file. To re-enable Guest Session, simply remove that file:

sudo rm /usr/share/lightdm/lightdm.conf.d/50-no-guest.conf
-1

Add this line:

allow-guest=false

to /etc/lightdm/lightdm.conf.d/20-lubuntu.conf. Save the file and reboot.

Not the answer you're looking for? Browse other questions tagged or ask your own question.