4

I've got a typical problem with my NVidia GPU. I recently installed Ubuntu 14.04 over windows 7 and completely whiped everything (on purpose), so I have a clean Ubuntu computer. Some specs:

  • ASUS KJ52c
  • RAM: 4 Gb
  • GPU: Hybrid NVidia 310M and Intel integrated Graphics
  • Processor: some Intel i5

On Ubuntu 13 I had the NVidia card up and running with bumblebee, and on Windows 7 it worked as a charm. Now, it's not recognized as hardware any more.

lspci | grep VGA shows:

00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 18)

lspci -v shows no hint of NVidia anywhere As such, I can't install any drivers for it, nor get bumblebee / nvidia prime running.

Any ideas would be very much appreciated.

7

First, the command you use for parsing video cards in this case:

lspci | grep VGA 

Is not a reliable way to do this.

Reason is that for some video cards, they're not listed as a "[0300] VGA compatible controller", they could be a "[0380] Display controller", or a "[0302] 3D controller", a more reliable way to do this is:

lspci -nn | grep '\[03'

Secondly, if you could confirm the nVidia graphic card was not listed in lspci output, I would suggest you to check your dmesg output, to see whether it could be detected on boot.

Or check your BIOS setting, some system allow users to select what video controller they want.

If it's not detected at all, it could be a kernel issue (as you said it's working on 13.xx), please open a bug with "ubuntu-bug linux" in your terminal.

  • Thanks for the quick reply. This is the output of $ lspci -nn | grep '[03' 00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 18) Is that only only card? In the BIOS I can either chose to let hybrid graphic work on windows XP / 7, or 'others', which is the option I use now. What should I look for in the dmesg output? It shows no sign of 'display', 'nvidia' or anything video related that is not controlled by Intel. – cvdsteeg Sep 14 '14 at 17:29
  • Yes, it seems that another card was not detected. Have you tired to switch to another option in your BIOS for that graphic setting? You could upload the output for lspci -nn and dmesg to paste.ubuntu.com – P.-H. Lin Sep 15 '14 at 3:34
  • Sorry it took so long. I uploaded both [dmesg] (paste.ubuntu.com/8574141) and [lspci -nn] (paste.ubuntu.com/8574145) to ubuntu. Find the output in the links. I also tried the other option in the BIOS, without any luck (the other option says 'Windows'). – cvdsteeg Oct 16 '14 at 14:14
  • @cvdsteeg, I can't see any sign of your nVidia card from these two attachments here. If it's not there even with BIOS option changed (maybe BIOS upgrade would help?), and you're confident that there should be a nVidia card on your system (maybe verify it with Windows), then I think it could be a bug (as you said it works with 13.xx). It's better to raise this issue with ubuntu-bug linux to open a bug against the kernel, since it's not picking it up correctly. – P.-H. Lin Oct 22 '14 at 9:57
  • Thank you for the suggestion. I wonder why I can't find any others with the same problem, since in 13.xx I encountered many Q&As for it. As a last resort, could it be the GPU hardware loosened its connection with the motherboard? – cvdsteeg Oct 29 '14 at 12:44
3

Ok, so after filing a bug against the kernel by terminal command 'ubuntu-bug linux', I got a very quick response from the team. The first wasn't helpful at first, but the second was, so I start there: Update the BIOS to the newest version (apparently 14.04 needs the latest BIOS update to notice the GPU) First: http://www.asus.com/Notebooks_Ultrabooks/K52JC/HelpDesk_Download/ 'an update to your BIOS is available (216).' If you update to this following: https://help.ubuntu.com/community/BIOSUpdate

the BIOS will update (I used a USB stick with the update file in the root directory, hit Esc at the ASUS logo and applied ASUSTEK EasyFlash)

Then automatically the machine will restart and recognize the NVidia hardware. I am now able to choose my driver (NVidia of Nouveau).

Thanks for the help!

0

Have you gone to "applications", Additional drivers and searched for avaliable drivers? Should list available opensource and proprietary drivers for your graphics card

  • Additional drivers doesn't show any drivers. Therefore I don't believe Ubuntu recognizes my card. Where should I search for available drivers? – cvdsteeg Sep 14 '14 at 17:35

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.