2

After looking through the Ubuntu instructions for creating a bootable USB I googled this and it seems like there's a plethora of different ways that one could do this. Here's what I've tried:

  1. Download the Ubuntu 14.04.1 desktop 64-bit iso.
  2. Find a link explaining how to create a bootable ubuntu iso.
  3. run dd if=path/to/iso of=/dev/sdd1 as per instructions.
  4. Try to boot. Nothing (blinking cursor, no activity until I hit Ctrl+Alt+Del
  5. Look for another link, this time telling me to install unetbootin
  6. Try to boot, get a Failed to load COM32 file menu.c32. The suggested fix is to look for a file. Checked. Doesn't exist on my system.
  7. Go and google again. This time I'm told debian ISOs can be copied directly. Maybe Ubuntu isos can be copied in this way? Nope.
  8. Check instructions on Ubuntu website again. Instructions less than helpful.
  9. Come here and ask.

Does anyone have a way of creating a bootable Ubuntu USB stick that works with Ubuntu 14.04 and can be used in a Debian system?

  • The menu.c32 error you got was a bug in your version of UNetbootin. Don't eve use the version in the repos. Instead, download the latest version from SourceForge. – John Scott Oct 11 '14 at 18:13
4

Bootable ISO images contain a partition table and boot record, and thus must be written to a disk rather than to a partition. The dd command you ran wrote the ISO image to sdd1, which is the first partition of the disk sdd. Write it just to sdd instead.

dd if=path/to/iso of=/dev/sdd

Of course, as ubuntu_tr says, always check that sdd is actually the correct device, or you might overwrite and destroy data on a totally different drive. I've made this sort of mistake, and while my backups saved me, it was a considerable inconvenience! Remember that a removable device's device node entry can change between mounts. (And if there are other systems you administer, make sure you're not accidentally SSH'd into one of them and inadvertently running dd on it remotely.)

Ubuntu users--people using Ubuntu to write the Ubuntu (or other) ISO image to the flash drive--will need to run dd with sudo:

sudo dd if=path/to/iso of=/dev/sdd

On Debian (the OS that Arman's using to create Ubuntu installation media), sudo is one of multiple widely used and supported options, the main other being to su to root with a separate root password. In contrast, Ubuntu systems almost always require sudo to run a command as root.

  • Right, I did not know that! Thanks :) – quant Sep 13 '14 at 7:06
0
dd if=Ubuntu\ 14.04.1\ desktop\ 64-bit.iso of=/dev/sdb bs=512k

sdb may change according to your system. Double check.

  • 1
    If the name of input file really has spaces in it, they will need to be quoted. For example, dd if='Ubuntu 14.04.1 desktop 64-bit.iso' of=/dev/sdb bs=512k or dd if=Ubuntu\ 14.04.1\ desktop\ 64-bit.iso of=/dev/sdb bs=512k. (The default names of Ubuntu ISOs don't have spaces, though.) – Eliah Kagan Sep 13 '14 at 7:02
  • You are right.I've corrected it. – ubuntu_tr Sep 13 '14 at 7:04
0

Actually, this is an error with either UNetbootin or Syslinux, imo.

Basically, Unetbootin installs this without 3 files whose functions are normally provided by Syslinux.

Try the following commands after doing a vanilla UNetbootin installation to a USB drive:

cd /usr/lib/syslinux/modules/bios/
cp libcom32.c32 /media/path/to/usb/drive/
cp libutil.c32 /media/path/to/usb/drive/
cp menu.c32 /media/path/to/usb/drive/

If you have any more questions about this, PM me.

I solved this using the instructions here: https://bugs.launchpad.net/unetbootin/+bug/1190256

And here: https://bugs.mageia.org/show_bug.cgi?id=11910

The Mageia guys are gs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.