I recently bought a Lenovo IdeaPad Flex 15 Touch Dual Mode 15.6” Notebook Intel Core i7-4500U and my wireless connection keeps disconnecting and the only way to reconnect it is to unplug my network adapter and plug it back in and some times I had to reboot. I have Ubuntu 14.04 .

I followed the instructions mentioned in this post: Wireless driver Lenovo Flex 14 Ubuntu 12 Ultrabook

I downloaded the stable backport drivers version backports-3.13-1.tar.gz which is same of my kernel version 3.13.0-35-generic but the command make fails I get this output

    sudo make
| Your backport package isn't configured, please configure it
| using one of the following options:
| To configure manually:
|     make oldconfig
|     make menuconfig
| To get defaults for certain drivers:
|     make defconfig-alx
|     make defconfig-ar5523
|     make defconfig-ath10k
|     make defconfig-ath5k
|     make defconfig-ath6kl
|     make defconfig-ath9k
|     make defconfig-ath9k-debug
|     make defconfig-b43
|     make defconfig-b43legacy
|     make defconfig-brcmfmac
|     make defconfig-brcmsmac
|     make defconfig-carl9170
|     make defconfig-cw1200
|     make defconfig-ieee802154
|     make defconfig-iwlwifi
|     make defconfig-media
|     make defconfig-nfc
|     make defconfig-regulator
|     make defconfig-rtlwifi
|     make defconfig-wcn36xx
|     make defconfig-wifi
|     make defconfig-wil6210
|     make defconfig-wwan
make[2]: *** [.config] Error 1
make[1]: *** [modules] Error 2
make: *** [default] Error 2

Any ideas how to get the wireless working?

Here's the output from my Ubuntu:

    $ sudo lshw -C network
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: eth0
       version: 08
       serial: 08:9e:01:f4:45:f7
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8106e-2_0.0.1 04/23/13 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:60 ioport:3000(size=256) memory:b0504000-b0504fff memory:b0500000-b0503fff
       description: Wireless interface
       product: Wireless 7260
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 73
       serial: 0c:8b:fd:94:13:1c
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=3.13.0-35-generic firmware= ip= latency=0 link=yes multicast=yes wireless=IEEE 802.11bg
       resources: irq:62 memory:b0400000-b0401fff

$ uname -a
Linux chaari-Lenovo-Ideapad-Flex-15 3.13.0-35-generic #62-Ubuntu SMP Fri Aug 15 01:58:42 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

1 Answer 1


Hope this is of some use as I had the same problem after the upgrade from 13.x and had made no changes to my network. I futzed around with it for quite a while, googled 'til my google got tired, etc., etc.

Finally, I got a simple wifi analyzer for my phone and watched the reception at my workstation. Amazing how much variation there was over a short period of time. And, as the db went more negative, Ubuntu would drop the connection.

Like you, it was a major hassle getting it back. Restarting the network worked - occasionally. Rebooting the machine worked - occasionally. And so on. I was lighting candles, standing on one foot and trying to hold my mouth just right.

In the end, I focused on getting a more stable signal to my workstation. I moved my access point to a better spot, added a bridge router using an old LinkSys router in the parts box for the other half of the house and voila! (or wallah if you live in Minnesota).

Everything has been completely stable since then.

My conclusion is that the networking in 14.x is just more sensitive and caring about the signal while 13.x took what it could get. Right or wrong, there you go!

  • 1
    i don't thinks this is the issue,In my case the signal is very good and I usually sit close to my access point.
    – Ahmed
    Sep 14, 2014 at 0:08
  • After googling it ,I found that a lot of other Lenovo users are also struggling to get their wireless works on Ubuntu and the issue is related to the wireless driver, and actually some of them have succeeded to compile the wireless driver for their own wireless card.
    – Ahmed
    Sep 14, 2014 at 0:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .