I have tried the install instructions https://help.ubuntu.com/community/Xbox360Controller but I keep getting an error message at the point when I'm executing the Make file.

warlord@warlord-laptop:~/xpad$ make
make modules -C /usr/src/linux-headers-2.6.32-32-generic SUBDIRS=/home/warlord/xpad
make[1]: Entering directory `/usr/src/linux-headers-2.6.32-32-generic'
   CC [M]  /home/warlord/xpad/xpad.o
/home/warlord/xpad/xpad.c: In function ‘xpad_wireless_connect’:
/home/warlord/xpad/xpad.c:291: error: implicit declaration of function ‘info’
/home/warlord/xpad/xpad.c: In function ‘xpad_open’:
/home/warlord/xpad/xpad.c:382: error: ‘struct input_dev’ has no member named ‘private’
/home/warlord/xpad/xpad.c: In function ‘xpad_close’:
/home/warlord/xpad/xpad.c:408: error: ‘struct input_dev’ has no member named ‘private’
/home/warlord/xpad/xpad.c: In function ‘xpad_probe’:
/home/warlord/xpad/xpad.c:496: error: ‘struct input_dev’ has no member named ‘cdev’
/home/warlord/xpad/xpad.c:497: error: ‘struct input_dev’ has no member named ‘private’
make[2]: *** [/home/warlord/xpad/xpad.o] Error 1
make[1]: *** [_module_/home/warlord/xpad] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.32-32-generic'
make: *** [all] Error 2

Why is this happening? I've also tried xboxdrv, and the jscalibrator is no longer supported in Ubuntu 10.04 LTS. And i also used lsinput and it shows my gamepad correctly in event 10 but not in js0 or js1.

   bustype : BUS_USB
   vendor  : 0x45e
   product : 0x28e
   version : 276
   name    : "Microsoft X-Box 360 pad"
   phys    : "usb-0000:00:1d.2-1/input0"
   bits ev : EV_SYN EV_KEY EV_ABS EV_FF

it is not necessary to install the controller in 10.04. it should just work, though not for games running wine that use the xinput interface i.e. many newer titles


I don't believe you can atm as the wireless Xbox 360 controller uses different protocols to standard bluetooth ones – and i don't think the protocol is out in the open yet either.

The USB based ones should work, however. From what i heaar, you don't need to compile drivers - it works out of the box. Have you tried it with any games?

  • Sorry for the bad grammar :) – Conor Rynne Jul 8 '11 at 17:36
  • the question is asking about the installation of a wired (USB) controller. – Christopher Kyle Horton Jul 9 '11 at 4:41
  • the controller i have is a wired. not wireless. I tried many different things to get it to work. is it an issue in the Make file shown in ubuntu [link]( help.ubuntu.com/community/Xbox360Controller). If so how should I change it to work ??? I am new to Linux terminal. – LHKWARLORD Jul 11 '11 at 14:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.