I have Windows 7 64 bit installed on one partition (the rest of the disk is unallocated). I made a live USB with the latest official Kubuntu 14.04 64 bit ISO. When I boot, there are two USB options: with UEFI or without. I have Windows 7 in "legacy BIOS mode" so I choose the one without UEFI.

When I boot into this one, I briefly see a splash screen (similar to this, but a black background), then the screen goes blank and enters sleep mode after a few seconds. Why does this happen and what can I do?

Note: I have also tried booting into the "UEFI: Sandisk Cruzer" option to see if it works. Installation starts normally (the monitor doesn't sleep etc.) but it doesn't recognize that Windows 7 is there, it thinks the entire disk is free space.

Thank you in advance.

Edit: After some more messing around and BSODs, I got my computer to work as I wanted (though I never found an exact answer to the original question). In case it helps anyone:

I followed this guide religiously. Part of it is to correctly put Windows 7 64 bit on a USB, where it links to another guide. I had trouble with it from another computer that has XP (the GPT option didn't appear), so I ended up installing Windows 7 non-UEFI, in order to make a UEFI Windows 7 USB in the first place. It was messy, but it worked. Then I installed Kubuntu with UEFI, it recognized everything well, and manual partitioning automatically chose the mount point of the EFI partition which was created by Windows.

2 Answers 2


If its partitioned already, and the free space is unallocated it, it may only be picking up the free space, resize the partition in Win7, all back to Win7, and use the Kubuntu's installers partitioner to install along side windows 7, theirs no need to partition it before hand.

  • Thanks, but I think Kubuntu really doesn't know it's there at all (it says 250GB of free unallocated space, and that' s the size of the entire disk). I have left enough space for Kubuntu, and yet it didn't even suggest to install them alongside. I suspect it is due to the fact that Windows 7 was not installed in UEFI mode.
    – meadow
    Sep 12, 2014 at 15:59
  • Thats strange, i suppose Kubuntu isnt set to recognize win 7, if you know how to set up the GRUB after, you can do it all manually.
    – JzJad
    Sep 12, 2014 at 16:02
  • I actually wasn't very surprised at this - my Windows installation uses MBR, and from what I've read this is different from UEFI standard.
    – meadow
    Sep 12, 2014 at 16:14
  • Also, how many partitions do you have one it already? just Windows 7?
    – JzJad
    Sep 12, 2014 at 16:18
  • Just Windows 7 (first the entire 250GB drive was free space, then in Windows setup I created a partition of 100GB or so, and selected it for installation. The rest remains free).
    – meadow
    Sep 12, 2014 at 16:21

From the Windows OS, you need to turn off things like fast startup (power option), dynamic partitions, (and raid if that's present). Then the installer should see your Windows partitions. You unsuccessful startup of live-media looks like a video problem, try the nomodeset option (F6 list) from the initial grub screen (with the Try/INstall choice). HOld down the shift key at power-on if that screen does not come up, but if you fix the partitions, maybe that will show also.

  • I've disabled fast startup in the BIOS and switched to IDE mode instead of AHCI. The UEFI installer still does not recognize the partitions. When I ran KDE partition editor, it also said the entire disk is unallocated. Dolphin, however, shows the Windows partition and I can access the files. The non-UEFI installer, with nomodeset, still shows a blank screen. The difference from before is now the monitor is not in sleep mode, just stays black. Any suggestions? Thanks. Edit: Perhaps it is relevant, my video card is R9 280x.
    – meadow
    Sep 12, 2014 at 17:05
  • You do not want to use UEFI to install Ubuntu if Windows is in BIOS mode. Either reinstall Windows in UEFI mode or just install Ubuntu in BIOS mode. Both systems must be in same mode to easily dual boot. You will need nomodeset with either BIOS or UEFI boot until proprietary video driver installed in actual install.
    – oldfred
    Sep 12, 2014 at 17:45
  • Thanks. As mentioned, BIOS mode had video problems (even with nomodeset). I will try to reinstall everything in UEFI.
    – meadow
    Sep 12, 2014 at 18:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .