0

my History

I got a PC with Intel 64 Bit Processor. There I have installed Ubuntu 14.04 LTS at /dev/sdb1 and Arch Linux at /dev/sda1.

Both swap onto /dev/sdb2.

I tried (with succes) to install Arch Linux onto a SD-Card (/dev/sdc) for my raspberry pi. There I tried to install vim to the SD-Card using pacstrap. This produced a few errors. Then I plugged off my SD-Card reader.

After rebooting my PC I saw a GRUB_RESCUE> promt. And the Line:

error:no such device:5a28b060-333c-479a-b5ed-58a7b9d8ae77.

This is the UUID of my Ubuntu partition (/dev/sdb1)

my first try

Then I used my amd64 boot repair disc and installed GRUB onto /dev/sdb. Then I had to disable /dev/sda in the Bios and Ubuntu is booting nicely.

Arch was'nt shown up at this moment.

Then I ran sudo update-grub and rebooted. Then Arch Linux was shown up but if I selected

Arch on /dev/sda1 my satadisc or somthing like that produced a ugly sound and my PC rebooted.

The output was

:~$ sudo update-grub
Grub-Konfigurationsdatei wird generiert …              #generating grub.cfg
Linux-Abbild gefunden: /boot/vmlinuz-3.13.0-35-generic     #Linux-image found
initrd-Abbild gefunden: /boot/initrd.img-3.13.0-35-generic
Linux-Abbild gefunden: /boot/vmlinuz-3.13.0-34-generic
initrd-Abbild gefunden: /boot/initrd.img-3.13.0-34-generic
Linux-Abbild gefunden: /boot/vmlinuz-3.13.0-33-generic
initrd-Abbild gefunden: /boot/initrd.img-3.13.0-33-generic
Linux-Abbild gefunden: /boot/vmlinuz-3.13.0-32-generic
initrd-Abbild gefunden: /boot/initrd.img-3.13.0-32-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
Arch auf /dev/sda1 gefunden             #found Arch on /dev/sda1
erledigt                          #done 

interesting is that GRUB says only 'found Arch on /dev/sda1'.

my second try

Then I tried to install GRUB onto /dev/sda and activated sda in the Bios. Then my machine produced again this ugly sound and I had to start again with the boot repair disc

my fourth try

is this here. I checked the /boot folder of Arch and of Ubuntu the differents are:

-Arch has got two initramfs.img (one is fallback) images

-Ubuntu has got a few initrd.img images(different versions)

-Ubuntu has got a few System.map files(see above)

-Ubuntu has got a few config files(again for the different versions)

-Ubuntu has got a few 'abi' files(what's that?)

And the filesystem of my Arch-partition is not damaged.

By the way I don't want to reinstall Arch because my installation is at a point where it would be really a lot work to rebuild the system.

Could it be that my MBR of /dev/sda are damaged?

Now I want to be able again to start both Operating Systems properly.

0

In /boot/grub.cfg is defined wich partition is used as root partition for the (unix-like)OSs.

Here in my case Arch is not booting, if his root partition is called by the name /dev/sdXY. I changed this using vim (vi should do it as well) using the command

:%s/\/dev\/sdXY/UUID=my-uuid/g

this substitutes every /dev/sdXY with my-uuid

| improve this answer | |
  • 1
    It's indeed always advised to use UUID or labels over the traditional way (/dev/sdX) because it's the only way to guaranty the persistence of partition names. – radriaanse Jan 2 '15 at 19:47
  • Yap, the grub-mkconfig uses only for better readability the /dev/sdXY form, better would be the UUID form, in the fstab,too. – LittleByBlue Jan 3 '15 at 9:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.