1

I am trying to auto mount 2 hard drives on a newly setup desktop.

I just installed Ubuntu 14.04 ran the updates and then immediately went to the Disk GUI in Ubuntu and set the auto mount on the ext4 partitions to auto mount.

I then reboot and the system then tells me just before it gets to the desktop that there was a problem mounting a drive and I can skip or go to recovery. I will skip and the 2nd hard drive will give the same message and then I skip.

After which I get to the desktop and then I cannot access the drives. When it tries to mount I will get an error that will read in essence

mount: wrong fs type, bad option, bad superblock on /dev/sdb1, missing codepage or helper gram, or other error n some cases useful info is found in syslog - try dmesg | tail or so".

I don't have a screen shot of the message but this is what it says when I do a mount -a from the terminal. Once I remove the auto mount setting I can then mount the drives by clicking on them in the file manager window.

I am a newbie to Linux and Ubuntu so I am at a loss . . .

  • have you tried to use fstab? try to insert a line like UUID=your-uuid /home/username/whereever/you/want auto user,rw,nodev 0 0 into your /etc/fstab – LittleByBlue Sep 12 '14 at 12:00
  • this is what the Disk GUI does, adds a statement to the fstab with that format. – eyarea51 Sep 12 '14 at 13:46
  • Please post the contents of your /etc/fstab. Also, what do you mean by "automount"? That's a different thing altogether. I think you mean mounting by default. – terdon Sep 12 '14 at 14:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.