27

My desktop (not the /home/user/Desktop folder) shows the contents of my /home/user folder. I don't know how I have done it and can I have some help on undoing it? The /home/user/Desktop folder just contains my desktop files which do not appear on my desktop.

47

You can change you desktop folder i.e the folder you want to use as your Desktop.

  • Open the ~/.config folder. (Press Ctrl+h to show hidden folders.)

    enter image description here

  • Open the user-dirs.dirs file in gedit.

enter image description here

  • Change XDG_DESKTOP_DIR to the folder you want to show as your Desktop folder. In your case it is XDG_DESKTOP_DIR=$HOME/Desktop

    enter image description here

  • Now restart nautilus using nautilus -q or killall nautilus and again opening it from Dash.
  • This answer is still up to date on Trusty 14.04.4. Thanks. +1 – Cbhihe Mar 21 '16 at 17:36
  • 1
    still works in 16.04 – Anwar Jul 3 '16 at 18:02
  • still works in 18.10 – Robertiano Apr 19 '19 at 7:19
16

As simply or shortly, You can set default folders with help of xdg-user-dirs-update command.

Run following command in your case:

xdg-user-dirs-update --set DESKTOP "$HOME/Desktop"

Then logout and login back to show/change effect.


From man xdg-user-dirs-update:

NAME
       xdg-user-dirs-update - Update XDG user dir configuration

SYNOPSIS
       xdg-user-dirs-update [OPTION...] [--set NAME PATH...]

DESCRIPTION
       xdg-user-dirs-update updates the current state of the users user-dirs.dir. If none existed before then one is created
       based on the system default values, or falling back to the old non-translated filenames if such directories exists. The
       list of old directories used are: ~/Desktop, ~/Templates and ~/Public.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.