I have just installed ubuntu 14.04 on my lenovo thinkpad S540. The problem is I have a touchpad all in one click (no seperate buttons) and the standard configuration is screwed up.

It's almost impossible to right click and sometimes when I left click is does right click. So I have to use a mouse otherwise I'm forced to use windows where the settings are just ok.

Also I cannot create a new document on /usr/share/X11/xorg.conf.d so I'm forced to adjust one of the files.

Does anyone have a solution?

  • Have you tried editing these files in directory /usr/share/X11/xorg.conf.d with sudo? Edit: like sudo gedit /usr/share/X11/xorg.conf.d/<somefile>
    – Fih
    Sep 12, 2014 at 10:11
  • Yes I have and the terminal tells me i'm not the root.
    – Joost
    Sep 16, 2014 at 13:11

1 Answer 1


You can edit the file /etc/X11/xorg.conf.d/50-synaptics.conf as follows. Moreoevr, I used xSwipe to add some "swipe" functionalities.

# Example xorg.conf.d snippet that assigns the touchpad driver
# to all touchpads. See xorg.conf.d(5) for more information on
# InputClass.
# DO NOT EDIT THIS FILE, your distribution will likely overwrite
# it when updating. Copy (and rename) this file into
# /etc/X11/xorg.conf.d first.
# Additional options may be added in the form of
#   Option "OptionName" "value"
Section "InputClass"
        Identifier "evdev touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
    MatchDevicePath "/dev/input/event*" 
    # disable synaptics driver pointer acceleration
    Option "Protocol" "event"
    Option "SHMConfig" "on"
        Option "MinSpeed" "1"
        Option "MaxSpeed" "1"
        # tweak the X-server pointer acceleration
        Option "AccelerationProfile" "2"
        Option "AdaptiveDeceleration" "16"
        Option "ConstantDeceleration" "16"
        Option "VelocityScale" "32"
        Option "TapButton1" "1"     # left click with one finger tap
        Option "TapButton2" "3"     # right click with two finger tap
# This option is recommend on all Linux systems using evdev, but cannot be
# enabled by default. See the following link for details:
# http://who-t.blogspot.com/2010/11/how-to-ignore-configuration-errors.html
      MatchDevicePath "/dev/input/event*"

#Section "InputClass"
#        Identifier "touchpad ignore duplicates"
#        MatchIsTouchpad "on"
#        MatchOS "Linux"
#        MatchDevicePath "/dev/input/mouse*"
#        Option "Ignore" "on"

# This option enables the bottom right corner to be a right button on
# non-synaptics clickpads.
# This option is only interpreted by clickpads.
#Section "InputClass"
#        Identifier "Default clickpad buttons"
#        MatchDriver "synaptics"
#        Option "SoftButtonAreas" "60% 0 0 5% 40% 60% 0 5%"
#       To disable the bottom edge area so the buttons only work as buttons,
#       not for movement, set the AreaBottomEdge
#        Option "AreaTopEdge" "4%"

# This option disables software buttons on Apple touchpads.
# This option is only interpreted by clickpads.
Section "InputClass"
        Identifier "Disable clickpad buttons on Apple touchpads"
        MatchProduct "Apple|bcm5974"
        MatchDriver "synaptics"
        Option "SoftButtonAreas" "0 0 0 0 0 0 0 0"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.