The problem is as simple as the title, I can't mount my rooted galaxy s4 phone(newest update 4.4.2) on my laptop(running Ubuntu 14.04 LTS). The error message is a consistent:

Unable to open MTP device '[usb:002,008]' 

with the numbers changing depending on how many times I try and which usb port I use.

Let me be clear of my precautions. I have USB debugging mode set to off, and stay awake mode on(so that phone screen doesn't lock).

Here's what I have tried:

I have installed the mtp-tools here and from others.

sudo apt-get install libmtp-common mtp-tools libmtp-dev libmtp-runtime libmtp9

I have edited the /etc/fuse.conf file to not include the last comment.

#Allow non-root users to specify the allow_other or allow_root mount options.
>> user_allow_other

I have edited the /lib/udev/rules.d/69-libmtp.rules to include my phone with vendorID and productID

# Galaxy S4
ATTR{idVendor}=="04e8", ATTR{idProduct}=="6860", SYMLINK+="libmtp-%k", ENV{ID_MTP_DEVICE}="1", ENV{ID_MEDIA_PLAYER}="1"

and I have edited the /etc/udev/rules.d/51-android.rules

ATTR{idVendor}=="04e8", ATTR{idProduct}=="6860", MODE=”0666"

I have installed gvfs.

Nothing has worked. Any suggestions are greatly appreciated. Will run any command and post outputs if needed.

  • 1
    Did you install the mtpfs package? – ubfan1 Sep 11 '14 at 21:32
  • Yes, I have installed the mtpfs package. – colin sinclair Sep 12 '14 at 12:40
  • It is starting to recognize it on and off now. Could very well be a usb cable problem. Will try some others to confirm. Sometimes it recognizes it and I can open and manage, sometimes it recognizes it then completely loses it, sometimes never mounts. – colin sinclair Sep 12 '14 at 14:11
  • I've found that for some reason it works fine if I have the phone connected when rebooting. – colin sinclair Sep 12 '14 at 19:09
  • What appears in dmesg after you plug the phone? Also under USB connection settings you may be able to use PTP instead of MTP, which might work – Wilf Feb 23 '15 at 18:32

found answer on android.stackexchange.com by user @Rat2000 on AskUbuntu.com:

Open a terminal in Ubuntu(Ctrl+Alt+T) and type this commands:

sudo add-apt-repository ppa:langdalepl/gvfs-mtp
sudo apt-get update

Then, launch Software Updater (previously known as Update Manager) and install the available updates. After you update everything restart pc.

if you want to revert back before making any changes:

sudo ppa-purge ppa:langdalepl/gvfs-mtp
  • For Then, launch Software Updater (previously known as Update Manager) and install the available updates. it may be simpler to run sudo apt-get upgrade... – Wilf Feb 23 '15 at 18:33

It seems to need some setting on the phone to be enabled, these can be hard to find. A post on the ASUS forum describes enabling developer options with USB debugging and then a menu should appear on storage setting page. This did not work for me but installing USB Driver ForAndroid allowed MTP and PTP options to be enabled.

Once installed gmtp started working fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.