3

I have used Windows 7 for a long time and thought to give Linux (Ubuntu) a try. I have two hard drives, one 120GB, other 1TB. First one is for OS and software, while the 1TB disk is for data and games. So I installed Ubuntu 14.04 on the 120GB disk (sda) and have done all those 10-things-you-should-do-after-installing-ubuntu. However, it did not want to mount the 1TB disk (sdb) at all saying that it's corrupted, but after two restarts it mounted (...?). I could access all my files but as a read-only disk. I installed GParted and got this message upon right-clicking /dev/sdb1 and selecting information:

Unable to read the contents of this file system!

Because of this some operations may be unavailable.

The cause might be a missing software package.

The following list of software packages is required for ntfs file system support: ntfsprogs / ntfs-3g.

Since I've been tackling this issue for about 5 hours now, I have heard and came across ntfsprogs and ntfs-3g but have only succeeded in installing ntfs-3g. ntfsprogs refuses to install for various reasons, e.g.

command

sudo apt-get install ntfsprogs

returns

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package ntfsprogs is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'ntfsprogs' has no installation candidate

What should I do? How can I make it read & write? It's an NTFS file system, but it's about 50% full and I can not lose that data. Is NTFS absolutely useless in Ubuntu (or Linux generally)?

Please help


UPDATE: Windows' disk checker said everything is normal, disk has been about 1% fragmented, and therefore defragmented, but nonetheless, the problem persisted. So I took a few days off to compress everything I had on it and transfered that data to cloud storage (Apple's Time Capsule) via Windows. I formatted the disk (to NTFS) and now it's empty and it indeed IS read&write in Ubuntu. But now I have a problem of being unable to access the Time Capsule from Ubuntu. I looked it up on the internet, but there are only solutions for earlier Ubuntu.

4

Ntfsprogs are included in the package ntfs-3g.

To install it run:

sudo su
apt-get install ntfs-3g ntfs-config

To repair the file system must use ntfsfix.

Ntfsfix is a utility that fixes some common NTFS problems.

Ntfsfix is NOT a Linux version of chkdsk. It only repairs some fundamental NTFS inconsistencies.

To run it:

sudo su
ntfsfix <options> <drive> 

Below is a summary of all the options that ntfsfix accepts:

-b, --clear-bad-sectors
       Clear the list of bad sectors. This is useful after  cloning  an
       old disk with bad sectors to a new disk.

-d, --clear-dirty
       Clear  the  volume  dirty  flag  if  the volume can be fixed and
       mounted.  If the option is not present or the volume  cannot  be
       fixed, the dirty volume flag is set to request a volume checking
       at next mount.

-h, --help
       Show a list of options with a brief description of each one.

-n, --do-nothing
       Do not write anything, just show what would have been done.

-V, --version
       Show the version number, copyright and license

Source: Ubuntu Manpage: ntfsfix - fix common errors and force Windows to check NTFS.

| improve this answer | |
  • That helped, but when I run ntfs fix on that disk, it returns anon@computer:~$ ntfsfix /dev/sdb1 Mounting volume... Error opening '/dev/sdb1': Permission denied FAILED Attempting to correct errors... Error opening '/dev/sdb1': Permission denied FAILED Failed to startup volume: Permission denied Error opening '/dev/sdb1': Permission denied Volume is corrupt. You should run chkdsk. also, how do I enter new row here? Enter posts the comment – Mat7 Sep 11 '14 at 19:39
  • @Mat7 it is preferred that you post error messages by editing the question. It's easier to read that way. That said, you cannot enter new lines in a comment. Also, did you try with sudo? – muru Sep 11 '14 at 20:13
1

I had a similar problem. NTFS file system was showing an error suggesting me to use ntfs-3g. But that didn't help.

Unable to read the contents of this file system! Because of this some 
operations may be unavailable. The cause might be a missing software package. 
The following list of software packages is required for ntfs file system 
support: ntfs-3g / ntfsprogs.

I solved it by the following way.

In Gparted

  • Unmount the Partition
  • Right click on the partition --> Format to --> Fat32 --> Apply all operation
  • After completing the operation, Revert back to NTFS by right clicking on the partition and select format to NTFS and apply all operation.

CAUTION: Be Sure to Backup the content of the partition before operation.

| improve this answer | |
1

I had the same problem, one of my drives with NTFS format was not able to mount.

I ran the command below :

sudo gparted

The result was shown in the below image

enter image description here

When I tried to mount it, this message was shown

Unable to read the contents of this file system! Because of this some operations may be unavailable. The cause might be a missing software package. The following list of software packages is required for ntfs file system support: ntfs-3g / ntfsprogs.”

I installed ntfs-3g using

sudo apt-get install ntfs-3g ntfs-config

After that I ran:

sudo ntfsfix /dev/sdb1

It worked for me

| improve this answer | |
0

Create a Windows Live USB, then follow the prompts to open a command line. After that, you can run chkdsk /f from there.

| improve this answer | |
0
sudo ntfs-3g -o remove_hiberfile /dev/sdXY /mnt   ## where X=drive and Y=partition
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.