I have been experiencing this problem ever since I re installed ubuntu 14.04

I can not force google sync account to work properly

I get this error every time I start chrome


First I thought it was fault of "passwords and keys" (I am talking about the password, you set after you install chrome) Well I disabled it and no go it still would give me that error. Then I've tried to re install chrome multiple times, even tried to install beta version, Still no go. While installing and re installing chrome I've signed in and signed out multiple times from google chrome but nothing helps. I even deleted chrome's folder from ubuntu file

Nothing seems to work, does anyone knows what to do in a situation like this ??

THank you in advance

ls -al .config/ | grep chrom shows this:

drwx------  7 levan levan 4096 სექ 11 03:52 google-chrome

her is (ls -al .config/google-chrome/) output

    ls -al .config/google-chrome/
total 7508
drwx------  7 levan levan    4096 სექ 11 04:00 .
drwx------ 27 levan levan    4096 სექ 11 03:15 ..
-rw-r-----  1 levan levan  213973 სექ 11 03:50 Certificate Revocation Lists
-rw-------  1 levan levan       6 სექ 11 03:15 Channels
drwx------  2 levan levan    4096 სექ 11 03:15 Crash Reports
drwx------ 12 levan levan    4096 სექ 11 03:24 Default
drwx------  2 levan levan    4096 სექ 11 03:16 Dictionaries
-rw-r-----  1 levan levan       0 სექ 11 03:15 First Run
-rw-------  1 levan levan   49236 სექ 11 04:00 Local State
drwx------  3 levan levan    4096 სექ 11 03:35 pnacl
drwx------ 16 levan levan    4096 სექ 11 03:56 Profile 1
-rw-rw-r--  1 levan levan 5163740 სექ 11 03:33 Safe Browsing Bloom
-rw-rw-r--  1 levan levan 1009218 სექ 11 03:33 Safe Browsing Bloom Prefix Set
-rw-r--r--  1 levan levan    6144 სექ 11 03:33 Safe Browsing Cookies
-rw-r--r--  1 levan levan    4640 სექ 11 03:33 Safe Browsing Cookies-journal
-rw-rw-r--  1 levan levan  113284 სექ 11 03:33 Safe Browsing Csd Whitelist
-rw-rw-r--  1 levan levan 1016684 სექ 11 03:33 Safe Browsing Download
-rw-rw-r--  1 levan levan   14532 სექ 11 03:33 Safe Browsing Download Whitelist
-rw-rw-r--  1 levan levan   36664 სექ 11 03:33 Safe Browsing Extension Blacklist
-rw-rw-r--  1 levan levan     696 სექ 11 03:33 Safe Browsing IP Blacklist
lrwxrwxrwx  1 levan levan      20 სექ 11 03:29 SingletonCookie -> 15826594184631451903
lrwxrwxrwx  1 levan levan      12 სექ 11 03:29 SingletonLock -> Genesis-3672
lrwxrwxrwx  1 levan levan      46 სექ 11 03:29 SingletonSocket -> /tmp/.com.google.Chrome.gBPfaM/SingletonSocket
  • 1
    I'm sorry, my bad. It should be ls -al .config/ | grep chrom (intentionally missing the e there).
    – Seth
    Sep 10 '14 at 23:52
  • I've added the information
    – Levan
    Sep 10 '14 at 23:56
  • 1
    Well that looks in order. How about ls -al .config/google-chrome/.
    – Seth
    Sep 10 '14 at 23:58
  • 1
    That looks fine as well. If the situation is really as bad as you say (in the comments on the answer below) and it were me, this is what I would do. I would purge the google-chrome folder from within ~/.config/google-chrome and then purge chrome (however you installed it), run apt-get clean and then reinstall chrome. Note that this is untested (I don't use chrome anymore) and may have unintended side effects (e.g. you may lose some bookmarks or whatever, if you had it stored in .config/google-chrome. Might save that as a last resort.
    – Seth
    Sep 11 '14 at 0:10
  • 1
    You tried all that? Humph. As an aside, I use Firefox and it works just fine for basic flash things (youtube, etc).
    – Seth
    Sep 11 '14 at 0:32
  1. Sign out of your Google Chrome account if signed in. And quit the browser.

  2. Delete the user data with this command: rm -r ~/.config/google-chrome/Default

  3. Relaunch Google Chrome. The error should now be gone, re-signin to your Google Chrome account and let it sync back your personal settings, extensions, and bookmarks.

Edit: Warning. If you don't have your bookmarks and such synced to your Google account then #2 will delete them with no recovery.

  • 1
    Are you sure this won't remove anything important?
    – Seth
    Sep 10 '14 at 23:53
  • Sadly I already tried that more then once, did not work
    – Levan
    Sep 10 '14 at 23:54
  • 1
    I did this today, it worked for myself.
    – headkase
    Sep 10 '14 at 23:55
  • Yes before i reinstalled the 14.04 i had the same problem and deleting the user account worked but now it will not budge
    – Levan
    Sep 11 '14 at 0:00

Make sure you use latest version of Chrome. If not install it.

sudo apt-get purge google-chrome-stable
sudo apt-get autoremove
sudo apt-get install google-chrome-stable

I get this now and then. Usually there are leftover/crashed chrome processes still open.

Kill them via Terminal/System Monitor, reopen chrome and the account-error is gone. At least for me this does the trick.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.