I have been trying to access the Date and Time setting in my Ubuntu 14.04 to modify the time (which is wrong).

I click in the hour in the top-right corner of the top bar, and then in "Date & Time Settings..." 1. Instead it takes me to "System Settings" 2. If I tried to click on "Time & Date" in "System Settings", it just closes the "System Settings" screen.

If I start the gnome-control-center from the command line I get the following:

(unity-control-center:4000): GLib-GIO-ERROR **: Settings schema 
'com.canonical.indicator.datetime' does not contain a key named 'show-year' 
Trace/breakpoint trap

I went to sudo dconf-editor and check in com > canonical > indicator > datetime. I can confirm that show-year doesn't exist. I am not sure if I can simply add a new variable there and if it is so, how?


1 Date and Time Settings

Date and Time Settings

2 System Settings

System Settings

7 Answers 7


That error message is odd. It does not find a key which indeed exists in one of the files belonging to the indicator-datetime package. This command reinstalls the package:

sudo apt-get install --reinstall indicator-datetime

Also, it should be noted that in Ubuntu 14.04 it's unity-control-center to open System Settings from command line, not gnome-control-center. It should be possible to have both the packages installed, but based on my experience there is a risk for conflicts/confusion. So I would recommend that the gnome-control-center package is uninstalled.

  • I already tried that. That isn't the problem since I found out that it works when I run the unity-control-center with root privileges.
    – toto_tico
    Commented Sep 11, 2014 at 18:33
  • @toto_tico: You may want to uninstall gnome-control-center. That package is not needed in Ubuntu 14.04, and might cause some confusion. Commented Sep 11, 2014 at 19:02
  • now this is strange. The Date & Time of the unity-control-center doesn't work, even with root privileges. However, the gnome-control-center does - but only with root privileges. I can infer from the layout that the gnome-control-center is redirecting to the unity-control-center, however this doesn't happen with root privileges.
    – toto_tico
    Commented Sep 12, 2014 at 0:43
  • 1
    @toto_tico: I see. As regards show-year, you may want to try sudo apt-get install --reinstall indicator-datetime, because it does exist in the original schema. Commented Sep 13, 2014 at 10:01
  • 1
    @toto_tico: Nah, my reputation is not important. ;) Possibly it will work 100% if you also uninstall gnome-control-center (and relogin). Commented Sep 14, 2014 at 6:57

try using this cli

pkill -f indicator-datetime-service

clock will appear directly.

credit : @Sneetsher

  • This is what worked for me after using tzdata to change the timezone at the command line, in Ubuntu 16.04LTS. Seems like a bug that should be fixed by now.
    – Berto
    Commented Nov 23, 2016 at 18:05

try to type "Time" (without the quote) in the right top search box of the "All Settings"

But likley this will crash too. Please start the "All Settings" / System Settings via command line: gnome-control-center

and try to access Date & Time, if it crash the terminal might give you an inside why.

Otherwise you can set the date and time via command line (see here: What is the command line statement for changing the System clock?)

  • The command line worked except that it return to the previous time after restarting the computer. My guess is that it is related to the timezone and not the time itself.
    – toto_tico
    Commented Sep 11, 2014 at 4:39

Another work around. Change the timezone in the command line:

  1. Open a terminal (Ctrl + Alt + T)

  2. Type and press Enter

    sudo dpkg-reconfigure tzdata
  3. Search for your timezone in the screens


Start the System Settings as root

  1. Open a terminal (Ctrl + Alt + T)

  2. Type and press Enter

    sudo gnome-control-center

  3. Click Date & Time

It doesn't fix the problem but it is good a workaround.


I had the same problem. Tried to access time and date, but nothing happened, and I intermittently received an error message. For me, the solution was to reinstall the GTK+3 timezone map widget in libtimezonemap1 via the synaptic package manager.


You can use this command also:

sudo killall unity-panel-service

The clock will appear on Desktop in the menu bar.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .