8

before this i was working on windows and my project was working proper. recently i moved to ubuntu and i am trying setup project on LAMP.

i have created host for this (windows i was running directly through localhost) and when i am running it getting 500 Internal server Error.

when i looked in my log file i got Invalid command 'AuthGroupFile', perhaps misspelled or defined by a module not included in the server configuration.

.htaccess File

#php_value zend.ze1_compatibility_mode off
AuthName "Restricted Area" 
AuthType Basic 
AuthUserFile /opt/lampp/htdocs/uniplex_mobile/.htpasswd 
AuthGroupFile /dev/null 

<Files manageurls.html>
require valid-user
</Files>
<Files addurl.html>
require valid-user
</Files>
<Files editurl.html>
require valid-user
</Files>

AddType application/x-httpd-php .php .htm .html

my project is on smarty framework.

can anyone help to solve this?

Thanks in advance

22

Try:

a2enmod authz_groupfile

This should help you.

  • 1
    Thank you, it's work, but it's need root permission with sudo, too. – Chu-Siang Lai Jul 24 '15 at 3:46
  • You make my day. It works properly but as @Chu-SiangLai said, you need sudo command to get it. Thank you very much :) – Error404 Feb 22 '16 at 3:35
1

Please use sudo for this command as it worked for me:

sudo a2enmod authz_groupfile
  • Welcome to Ask Ubuntu! ;-) Could you please review my edits and also review the editing help to improve the readability of your questions in the future... ;-) – Fabby Mar 19 '15 at 9:02

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.