The internet keeps cutting out every several minutes, sometimes it lasts longer but it happens eventually. I can still use the internet if I disconnect from the menu and click connect again. Any help would be appreciated :)

Details of my Wireless Card:

Wireless card: 04:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8187SE Wireless LAN Controller (rev 22)

I'm just running a plain old fully up to date 64-bit Ubuntu (Kernel 2.6.38-10-generic)

How the kernel recognises my wireless card:

       description: Wireless interface
       product: RTL8187SE Wireless LAN Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:04:00.0
       logical name: wlan0
       version: 22
       serial: 00:24:21:cf:89:f6
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=r8180 latency=0 multicast=yes wireless=802.11b/g
       resources: irq:17 ioport:3000(size=256) memory:fa000000-fa003fff
       description: Ethernet interface
       product: RTL8111/8168B PCI Express Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:05:00.0
       logical name: eth0
       version: 03
       serial: 00:03:0d:de:97:eb
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full ip= latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:43 ioport:4000(size=256) memory:f6000000-f6000fff memory:f4000000-f4003fff memory:f4020000-f403ffff

I'm just using standard network manager, not customised anything really..

  • Can you try to install linux-backports-modules-cw-2.6.39-generic, then reboot and see if you have the problem still? – Jorge Castro Jul 10 '11 at 18:57
  • I have installed what you suggested Jorge but the internet is still dropping out here, will try fossfreedom's suggestion now – user931 Jul 10 '11 at 19:16

Dropped WiFi connections can either be environmental or software related.

I'll try to keep this as generic as possible, so that the answer could apply to any WiFi cards.

Three environmental areas that you should consider before delving into the software suggestions below:

  • WIFI Encryption - Try changing the encryption method on your WIFI router, see if that results in a more stable connection.

  • WIFI Router itself - Try moving to a new access point, do you still have connectivity issues?

  • WIFI Channel - Try changing the channel your router is communicating on. In your area, there may be too much traffic on the channel you selected.

Once you've ruled these areas out, five software possible avenues you could consider:

  1. Looking to see if any WiFi Backport exist and if so, installing the appropriate package
  2. See if this is a 64bit vs 32bit issue
  3. Trying a newer Kernel, either the next available stable kernel OR testing the very latest alpha/beta Ubuntu version which contains the latest release candidate kernel
  4. Disabling the power management of your wireless card
  5. (the choice of very last resort) using NDISWrapper


The kernel developers often release a software package containing updates for WiFi devices derived from the latest or most recent kernel.

For Natty, this package is called linux-backports-modules-cw-2.6.39-generic (thanks Jorge). This package can be found either in the proposed repository or in the backport repository. Tick the appropriate checkbox in Software Sources and Reload the latest updates.

Open either Software Center or Synaptic Manager and search for the package named (or similarly named) as above. If the package is available, install the package, reboot and see if the WiFi connection is more stable.

64bit vs 32bit

As linux matures, 64bit vs 32bits issues should reduce. However it is not unknown that a 64bit installation can be more unstable compared to a 32bit installation - and visa-versa.

For your card, I found a bug report for your Wireless card here that describes your symptoms - 64bit kernel, wifi drops connection randomly.

Take a backup of your system first using, for example, Clonezilla, so that you have something you can easily restore from.

Try installing the 32bit version of Natty. See if your connection is more stable. You could also test the other suggestions in this answer in this 32bit configuration.

Newer Kernel

Testing a newer Kernel can sometimes cause instability issues - for example boot and black-screen issues. I would recommend you remove any Additional Hardware graphic drivers (e.g. ATI or Nvidia) first. I also recommend that you have a good backup for example, using CloneZilla which you can restore from.

Look for the next stable mainline kernel from here on LaunchPad.

Looking at the change lists on kernel 2.6.39, it does mention some updates for your card.

You can install the 2.6.39 kernel as described in my answer here.

Disabling Power Management

Sometimes wireless cards can have Power Management modes. Its not unknown for these modes to be buggy in linux. Switching off power-management can sometimes help.

You may have to do some Google research to see if there is a specific method to disable Power Managment. Below is a method I've used in the past for some cards.

From a terminal type:

gksu gedit /etc/pm/power.d/wireless

If the file opened contains any statements then add the following line (if it doesnt already exist)

/sbin/iwconfig wlan0 power off

If the file opened is empty then add the following


/sbin/iwconfig wlan0 power off

Now copy and paste the following:

sudo chmod +x /etc/pm/power.d/wireless

Then reboot.



Note - NDISWrapper can cause black-screen issues on boot - so have a good backup for example, using CloneZilla which you can restore from.

NDISWrapper was at one time a few years ago, one frequently used method for wireless cards because the kernel had so few wireless driver support.

Its fallen out of favour in recent times for many reasons that I wont go into...

To be honest, RTL8187se has been in the kernel for some time so the following suggestion should be considered as a last resort.

Search for ndisgtk in the software center and install

Now download the windows xp drivers, in your case from Realtek

Extract from the zip file.

Using ndisgtk - navigate to the folder - RTL8187SE - WinXP and point ndisgtk to the .inf file. Hopefully now (maybe after a reboot) network manager should use this driver in preference to the RTL8187SE kernel driver - n.b. hopefully you dont have to blacklist the kernel.

| improve this answer | |
  • I've tried what you and Jorge suggested but the connection still keeps dropping :( – user931 Jul 11 '11 at 9:22
  • I tried everything suggested but it still drops, I guess it's time to give up hope? – user931 Jul 12 '11 at 20:52
  • I tried your new NDISWrapper suggestion but after doing that and rebooting, I was greeted with a black screen and I couldn't actually do anything.. I've played with NDISWrapper before for my old laptop and didn't have problems then. Anyway, I ended up having to do a fresh install. Next? ;) – user931 Jul 13 '11 at 23:18
  • hmmm - I've dug around (and around...) - but all I can find is that this wireless card doesnt work very well under 64bit but does work for 32bit. Similar observations for 64bit vs 32bit Windows 7 (see the linked debian bug report). I've run out of ideas other than either using 32bit Natty or buying another manufacturers wireless card. 3 days to go. Hopefully someone else can chip in and get your card working under 64bit Natty. – fossfreedom Jul 14 '11 at 9:33
  • I'm currently testing out a fully up to date 64-bit Oneiric install since the issue with Natty the other day.. The wireless has dropped 2 or 3 times since then, which is a lot better than with under Natty! – user931 Jul 14 '11 at 11:50

It sounds similar to an issue as I used to get in Meego (no not Ubuntu) where the wifi used to cut in and out so much so it was a real pain.

I remember at the time that it was fixed by editing the rc.local file with a really easy fix which worked (albeit in Meego) but

cd /etc/

gksudo gedit rc.local

Insert the following lines if they are not already there (or uncomment them)

ifconfig wlan0 down
ifconfig wlan0 up

(originally in the older meego bug we used to have to change wlan0 to eth1 (dont know why but it used to mean us using eth1 not wlan0 )

old meego bug

BUT this was a broadcom issue however it seemed a little similar to what you were describing

| improve this answer | |
  • can I suggest you change eth1 to wlan0 since this is a wireless issue - you are suggesting bouncing the fixed ethernet port (also worth putting code tags as well) – fossfreedom Jul 11 '11 at 15:48
  • agreed. I will adapt – andybleaden Jul 12 '11 at 6:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy