31

I have a mysql that has been working fine but now will not start. All I've been able to accomplish is using

sudo start mysql

which generates the following error:

start: Rejected send message, 1 matched rules; type="method_call", sender=":1.5" (uid=1000 pid=1678 comm="start mysql ") interface="com.ubuntu.Upstart0_6.Job" member="Start" error name="(unset)" requested_reply="0" destination="com.ubuntu.Upstart" (uid=0 pid=1 comm="/sbin/init")

I've tried googling sections of it, but it seems this is basically a useless error. Anyway I can get more information about what is going on?

  • 2
    Did you find a solution? – Robert Sep 16 '14 at 14:06
41

The problem is this:

uid=1000

That bit means that the user that contacted Upstart to perform the start action has the uid 1000 (not root, root is 0). That uid is usually assigned to the first non-system user. Something must be severely wrong with your usage of sudo, or sudo itself, because the command is not properly escalating to root.

You can see the same error with this command, for comparison (note the absence of sudo):

start --system mysql
|improve this answer|||||
  • 9
    so do sudo start mysql got it – ThorSummoner Aug 27 '15 at 19:27
  • The original question appears was using sudo. This did help me with the same error though, but I wasn't using sudo in the first place. – Elijah Lynn May 9 '19 at 7:44
12

The recommended way to start services is to use the service command:

sudo service mysql start
|improve this answer|||||
  • IMO, start is a shorthand for service $1 start, so it should be the same. – Braiam Sep 10 '14 at 14:29
  • 6
    @Braiam start is actually initctl (a symlink), which does initctl start when called as start. – muru Sep 11 '14 at 22:38
  • How is initctl start different than service ... start? – Elijah Lynn May 9 '19 at 7:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.