2

So I just ventured into the land of Ubuntu. It was a pleasant stroll until I came onto the chasm of users and permissions.

I installed transmission-daemon. Everything looked nice and easy, but once a download gets going, it gives a shiny red "Permission denied" to my download path. So I started reading up on permissions. Learned how to use "gksudo nautilus" amongst other things. But things didn't clear up at all. The download folder had no owner as far as I could see when I worked through the files dialog. With "gksudo nautilus", it just crashed the window. I couldn't even see who owned it. Through the terminal it seemed all set like it should. Both owner and group set to debian-transmission.

Then I stumbled on this topic: Transmission daemon: permission denied even if debian-transmission has root group and I thought: "Hey, those are clear instructions I can follow! Let's do this!". Now I'm stuck with a transmission that won't even start. It gives me a nice "transmission-daemon start/running, process 29525". But that's it. It stops right away and it's gone. No error or anything that my untrained eyes can work with.

Can somebody help me with this? Some commands that can help me get further? Or should I just remove the whole thing and start over? Thanks in advance.

//Edit

I have followed muru's instructions and the daemon is back up and running but I am getting this error now:

Error: Unable to save resume file: Permission denied

My download folders look like this:

drwsrwxrwx 2 debian-transmission debian-transmission 4096 sep  8 22:35 completed
drwsrwxrwx 2 debian-transmission debian-transmission 4096 sep  8 22:35 incomplete
drwxrwxr-x 2 erik                erik                4096 sep  8 22:35 torrents

And the info folder is this:

drwsrwxr-x 5 erik                debian-transmission 4096 sep 10 13:43 info

Running transmission-daemon --log-debug --foreground gives me Couldn't read "/home/erik/.config/transmission-daemon/stats.json": No such file or di rectory (utils.c:201)

Even though it can't read the stats.json and I think it is somehow ignoring my settings file (whitelist for ip's isnt working). It does succesfully download to /home/erik/Downloads. Then I stop the service. And restart it with the command that I thought was correct sudo service transmission-daemon start and it starts making a mess again. So I don't know, is the fact that it's a service making a difference?

  • Can you run transmission-daemon --log-debug --foreground as well (after stopping the service)? – muru Sep 10 '14 at 11:51
  • I did this and added some stuff to the post. – Erik Sep 10 '14 at 12:35
1

The last command in that set:

sudo chown your_user -R /etc/transmission-daemon/settings.json 

sets your user as the owner of the settings file, and that file has read-permissions only for the owner by default. Transmission won't even be able to read it. Try:

sudo service transmission-daemon stop 
chmod g+rw /etc/transmission-daemon/settings.json 
sudo service transmission-daemon start

Since the commands don't change the group ownership of that file, giving it group read/write permission should be enough to get Transmission to start.

There are other problems as well, so I suggest these modifications as well:

chmod g+rw /var/lib/transmission-daemon/info/
chmod u+s /your_path/progress /your_path/completed

This will:

  1. Give the daemon the necessary write permissions on /var/lib/transmission-daemon/info/, where it stores the current status.
  2. Ensure that files created in the download and temporary folders are owned by you, by making the folders setuid.
  • It is not running I'm afraid. It is not showing when I use ps aux. It gives me an error when I try to stop or pause the service. And the web interface doesn't work (it did before). – Erik Sep 10 '14 at 10:43
  • @Erik what happens when you run transmission-daemon manually? What error does it show when you stop it? – muru Sep 10 '14 at 10:54
  • Oh, crap. The last command in that set: sudo chown your_user -R /etc/transmission-daemon/settings.json sets your user as the owner of the settings file, and that file has read-permissions only for the owner by default. Transmission won't even be able to read it. Try: sudo service transmission-daemon stop; sudo chmod g+rw /etc/transmission-daemon/settings.json; sudo service transmission-daemon start – muru Sep 10 '14 at 10:56
  • That did the trick. It runs again now. I got this new error now: Error: Unable to save resume file: Permission denied so I still have work to do. But at least it is running again. – Erik Sep 10 '14 at 11:22
  • @Erik it's the same bug: /var/lib/transmission-daemon/info/ does not have group write permissions and we have set the owner to your user. Another chmod g+w needed. – muru Sep 10 '14 at 11:28
0

I had a similar problem with transmission.

I tried changing permission and all that. In the end I just deleted :

/home/user_name/.cache/transmission
/home/user_name/.config/transmission

Restarted transmission. Runs without any problems now.

Regards.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.