0

My Info: http://www.alsa-project.org/db/?f=cbf6b64acdde8c2f2d3a24cae453b4f2817e8a1e

Today I updated Ubuntu base via Software Updater and now my sound does not work out of built in laptop speakers or the headphone jack. Software Updater may have updated other things besides Ubuntu base, but unfortunately I wasn't paying much attention.

This log is about the time when update occurred and the problem began, but it seems to be mostly vlc related stuff, so I don't know.

/var/log/apt/history.log

Start-Date: 2014-09-09  12:42:13

Commandline: aptdaemon role='role-commit-packages' sender=':1.241'

Upgrade: vlc-plugin-notify:amd64 (2.2.0+ppa2.1, 2.2.0+ppa2.2), libvlccore8:amd64 
(2.2.0+ppa2.1, 2.2.0+ppa2.2), vlc-nox:amd64 (2.2.0+ppa2.1, 2.2.0+ppa2.2), vlc-plugin-
samba:amd64 (2.2.0+ppa2.1, 2.2.0+ppa2.2), libnss3-1d:amd64 (3.15.4-1ubuntu7, 
3.15.4-1ubuntu7.1), vlc-data:amd64 (2.2.0+ppa2.1, 2.2.0+ppa2.2), libnss3-nssdb:amd64 
(3.15.4-1ubuntu7, 3.15.4-1ubuntu7.1), libnss3:amd64 (3.15.4-1ubuntu7, 
3.15.4-1ubuntu7.1), vlc:amd64 (2.2.0+ppa2.1, 2.2.0+ppa2.2), libvlc5:amd64 
(2.2.0+ppa2.1, 2.2.0+ppa2.2)


End-Date: 2014-09-09  12:43:01

The Sound Settings (unity-control-center sound) does not show any devices.

Sound Settings

AlsaMixer, after F5 (show all) has 2 channels I can change PCM and Digital, I swear there used to also be a master channel (and maybe others) before.

AlsaMixer

Tried:

pulseaudio -k

pulseaudio --start

sudo alsa force-reload

sudo apt-get remove --purge alsa-base pulseaudio 

sudo apt-get install alsa-base pulseaudio

sudo alsa force-reload
  • older kernel and newer rc kernel

  • aplay /usr/share/sounds/alsa/Front_Center.wav says it played, but no sound heard

I ran the alsa info script:

wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh

My Info: http://www.alsa-project.org/db/?f=cbf6b64acdde8c2f2d3a24cae453b4f2817e8a1e

  • do you have a file at /etc/pulse/default.pa ? if not, see askubuntu.com/a/225499/167115 and copy the linked file to that location – mchid Sep 10 '14 at 8:51
  • Also, when you install ALSA it is first set to mute by default and you have to take it off mute. – mchid Sep 10 '14 at 8:55
  • hda-intel 0000:00:1b.0: Codec #0 probe error; disabling it... that's your problem. Report a bug to Ubunto or ALSA. – CL. Sep 10 '14 at 9:05
  • @mchid: I have default.pa, but I reset it anyways, no luck. ALSA is not muted (as far as I can tell). – KSM0071 Sep 10 '14 at 18:27
0

Booted into recovery mode via grub and the sound worked as expected. Then I booted normally and the sound worked.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.