Neither can I install Ubuntu 11.04 64 bit nor can I just run the OS from a USB drive. It just shows a blank screen when I try to run it, and when I try to install it, the screen just flickers with rainbow colours.

I need some linux on it, what other distribution is known to work on these machines? I would be most comfortable with ubuntu if there is a workaround.

  • yayu - do you see anything at all when you boot from USB such as a purple screen with an icon at the bottom, before the black screen? – fossfreedom Jul 7 '11 at 20:17
  • @fossfreedom yes, I see an option to either run ubuntu or install it. Selecting install gives the rainbow flicker screen, and selecting run gives a plain white screen after the purple ubuntu logo and then nothing happens. – yayu Jul 7 '11 at 20:21
  • bottom right should be some options you can choose - try "nomodeset" before choosing the option "try without installing" - does the desktop appear? – fossfreedom Jul 7 '11 at 20:35
  • @fossfreedom That does not result in anything but a blank screen – yayu Jul 8 '11 at 6:36

I had the same problem with my HP tx2000, I downloaded the alternate installer and it worked. it should let you at least install ubuntu.

If you still get a black or flickering screen after the installation, try changing the boot options:

  1. If the menu doesn't appear and boots straight into Ubuntu, restart and press the Shift key until the menu appears.

  2. Select the Ubuntu default kernel (usually the first option) and press the E key to edit.

  3. Go to the end of the line that contains the kernel (starts with linux/boot/vmlinuz) by pressing End.

  4. type nomodeset

  5. Press Ctrl+X to boot

If that doesn't work, try using the option acpi=off.

Once you boot into Ubuntu, make sure you have internet connection. Ubuntu will detect and show you in a window the hardware that requires restricted (i.e not open source) drivers. It will then download and install them.


Try using 11.10 of Ubuntu. They seem to have fixed the issue with the video. I'm not sure but I think the issue was related to the Hybrid SLI video mode that the Alienware has. I'm running Ubuntu 11.10 as I write this on an M17x. Good luck. :)

  • Rodrigo has some query posted as an answer addressed to you. – yayu Oct 27 '11 at 20:40
  • Kaius how did u manage to do that? I'trying but I cant get it to run... I've my post was deleted by a moderator and I understand that it not fit... so I've created a question post Need help to install Ubuntu on Win7 Alienware M17xR3, intalling not working like u suggested... Thankz for the suggestion Yayu – Rodrigo Oct 28 '11 at 0:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.