1

TLDR Version:

Problems with Grub2. Boots straight into Grub terminal. I get some "failure reading sector errors" (details below). I've tried running boot repair several times, with a few different options checked at this point (details below), but I can't get it to work. Dual boot situation, was able to access Windows when problem started, but now selecting Windows brings me to a Grub terminal as well.

http://paste.ubuntu.com/8298591


Full Details:

I've got some issues going on with my Grub installation. I'll detail what's going on first, and then I'll try and give the background of what's been going on.

Yesterday evening, my Ubuntu froze up on me and I had to perform a hard/manual shutdown of the computer. When I went to reboot, it wasn't allowing me to boot into my Grub screen (I believe at the time I was getting the Grub terminal, but I'm not 100% certain at this point anymore). Anyways, this isn't the first time this has happened (more on that later), so I went ahead and ran the Boot Repair tool. I had a few problems with it last time, but I figured I'd try again anyways.

First attempt, I got the notice that my PC was in Legacy mode but I disregarded it, and proceeded to run the repair anyways in default mode. No luck.

Second attempt, I got my computer out of Legacy mode, booted into Ubuntu through the EFI (on a flash drive), and ran the repair again. Default mode. It booted into the Grub menu and it looked like it would work. I selected Ubuntu, and I get a bunch of errors:

error: failure reading sector 0x74706da0 from 'hd2'.
error: failure reading sector 0x74706d00 from 'hd2'.
error: failure reading sector 0x0 from 'hd2'.
error: failure reading sector 0x74706da0 from 'hd2'.
error: failure reading sector 0x74706d00 from 'hd2'.
error: failure reading sector 0x0 from 'hd2'.
error: no such device: 4c536822-6b4d-4c08-88e3-2694bc7cd0be.

After that, it takes me to the Grub prompt where I just get the standard:

Grub>

Interesting to me, I have 2 options in the EFI/BIOS for Linux (not including the USB option), and a Windows option as well. It does not matter at all which option I take (less the USB), I always end up at the Grub terminal - even if I select Windows.

I've tried the backup and rename Windows EFI option as well (sort of blindly, primarily because it was one I could simply set back if it didn't change anything). It didn't change a thing. FWIW, at one point this evening, I was still able to boot into Windows while Linux was unavailable.

The history of this problem is that it just did a similar thing just over a week ago. I fixed it with the boot repair tool, with the default settings. However, when I did fix it, I wasn't able to boot into Linux with the EFI. I had to go through in Legacy mode, which I suspect was a problem that I created. I think I probably booted into Legacy mode and ran the repair from there, but I'm not quite certain at this point. Both times I've had these problems it came after a unplanned hard shutdown - power once & frozen OS the second time.

Here's a boot repair log that I just generated with the most recent changes represented.

http://paste.ubuntu.com/8298591/

My initial thought with all of the disk access errors would tell me that I might have a disk problem, and particularly since I had a similar issue just about a week ago. However, I'm fairly certain I've got an issue with the actual EFI on HD1 right now, due to the fact that I can't even get into Windows - and with my limited knowledge of EFIs, I don't really think that can be tied to each other... but I don't know - hopefully someone can tell me! :)

Thanks for reading and thanks in advance for any help you might be able to provide.

Kind regards.

  • I'm getting an error when I run Boot Repair, and I'm just cautiously playing with some settings. The most recent report is here: paste2.org/UwNYFghK ---- I checked use the standard EFI file this time, and that's all I changed from default. I'll update as soon as I reboot. – Josh41 Sep 12 '14 at 11:44
  • The above attempt looked promising at first - Grub2 came up this time, but when I attempted to select Linux/Ubuntu it error'd out. I got a failure to read sector error again, press any key to exit, which brought me back to the screen, and so on. Ultimately, it froze again, had to hard reset, and now I'm back to where I was before the last "repair". – Josh41 Sep 12 '14 at 12:02
0

After a hard shutdown you often have to make repairs. With Windows is it chkdsk, but with Linux and ext formats it is fsck,

From liveDVD/Flash so everything is unmounted,swap off if necessary, change example shown with partition sdb1 to your partition(s) e2fsck is used to check the ext2/ext3/ext4 family of file systems. -p trys fixes where response not required

sudo e2fsck -C0 -p -f -v /dev/sdb1

if errors: -y auto answers yes for fixes needing response, also see man e2fsck

sudo e2fsck -f -y -v /dev/sdb1

You may need to run both on sdb1, sdb3 & sdb5.

  • Thanks for the suggestion. I'm familiar with chkdsk, but new enough to Linux that I had no idea where to go with that. Anyways, I went ahead and ran fsck, but it did not find any errors, so unfortunately it's not that simple. I'll play with it more this evening & if I get anywhere, I'll update with whatever I happen to find / try. – Josh41 Sep 12 '14 at 11:23
  • You also have an UEFI install on sda and a BIOS install on sdb. I now prefer gpt partitioning on any drive that will not ever have Windows installed in BIOS mode. Ubuntu can boot from gpt partitioned drive with BIOS or UEFI. Then you could convert later. See also this thread on mixed UEFI/BIOS boot. askubuntu.com/questions/522363/… – oldfred Sep 12 '14 at 17:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.