8

I have been googling for hours trying to find a way to get rid of the annoying gpg-error referring to the link below.

W: GPG error: http://download.opensuse.org Release: The following signatures could not be verified because the public key is not available: NO_PUBKEY 9A5EED8CBCA00D90

I have tried:

sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 9A5EED8CBCA00D90

but to no avail.

Google Translated error message:

The following signatures could not be verified because the public key is not available

10
  • 1
    Please translate the error message...
    – Jan
    Sep 9 '14 at 20:49
  • 1
    I don't see why openSUSE keys should be in the Ubuntu keyserver. Look through the openSUSE documentation, I'm sure they'll have steps to get the key.
    – muru
    Sep 9 '14 at 20:58
  • W: GPG error: download.opensuse.org Release: The following signatures could not be verified because the public key is not available: NO_PUBKEY 9A5EED8CBCA00D90
    – tomoqv
    Sep 10 '14 at 7:57
  • @EliahKagan: I have looked at the suggested duplicate and tried everything there, but it has not helped.
    – tomoqv
    Sep 10 '14 at 8:01
  • 1
    Aah, thanks! I found the culprits in /etc/apt/sources.list.d/trojita-nightly.list and /etc/apt/sources.list.d/trojita-nightly.list.save, so I removed both files and now the error is gone.
    – tomoqv
    Sep 10 '14 at 18:16
17

If you don't need the source, you can look up and remove/comment the source entries. To find out where they are:

grep -iR opensuse /etc/apt/sources.list*

In all likelihood, they are in the sources.list.d folder, so this command should disable such entries:

sudo sed -i '/opensuse/ s/^/#/' /etc/apt/sources.list.d/*.list

You can ignore files with the .save extension.

Not the answer you're looking for? Browse other questions tagged or ask your own question.