First of all sorry if there is a duplicate, I haven been able to find it. I have found a huge lot of questions in the other sense: Disabling BT, but that's not what I want.

I would like to know how to get my BT working as soon as possible in order to be able to type in my password at login or at least have it working when the desktop loads.

My machine is a HP ProBook 4515s. I am almost sure that the BT is linked to the WiFi card so that it may be necessary to have that first enabled.

Would it be possible to just change the startup order of the WiFi service in /etc/init.d?

In any case, I still need to cajole the bluetooth thingy to wake up as soon has he can... and while I am trying to RTFM as hard as possible, I just find a ton of people asking how to DISABLE it while I want it the other way around:)

THX mates


Open sudo gedit /etc/rc.local file.

And add the following line before the exit 0:

rfkill unblock all

Now enter the following line in a terminal:

sudo reboot

After system boots up your bluetooth would be Enable.

  • Whoaaa!! Awesome, THX. It worked perfectly. That was actually the main reason for switching from Fedora 20 to Ubuntu, that I was a bit ired of having to tamper with > 20 files to get a single piece of hardware working. THX mate ;) – runlevel0 Sep 14 '14 at 10:14
  • @runlevel0 thank you why not accept see G_P's answer he/she edited by according my answer at 17:50 – αғsнιη Sep 14 '14 at 10:27
  • sorry, was trying to up-vote his/her answer so that both got credit, as there is some useful info there too. But I have set yours as accepted now as it was what I actually did ;) (I used nano, however) – runlevel0 Sep 14 '14 at 10:33

You can enable Bluetooth as well as WiFi upon startup by adding following in Startup applications

  • Open Startup Applications
  • Now click on add button and add following command in command box.

    rfkill unblock all

  • Put any name you want in Name box.

Now on every login it will enable your Bluetooth as well as WiFi.

Alternatively you can also add this to your /etc/rc.local file.

  • Open it using gksudo gedit /etc/rc.local.

  • Add the above line in it before exit 0.

  • Save and reboot.

  • Good one too!!! I followed the answer above but I was actually searching for a GUI tool to do that (like in the old gsysvinit) until I get used to systemd... THX – runlevel0 Sep 14 '14 at 10:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.