0

Now after updating from 13.10 to Ubuntu 14.04, my Brother DCP-7055 still prints, but still does not scan. I've reinstalled the Brother drivers. Twice. (I'm now using 0.4.2-3)

lsusb says:

Bus 003 Device 011: ID 04f9:0248 Brother Industries, Ltd DCP-7055 scanner/printer

Whereas scanimage -L says

device `brother4:bus2;dev1' is a Brother DCP-7055 USB scanner

So I tried (as root):

ln -s /dev/bus/usb/003/011 /dev/usb/scanner

So, now instead of "failed to open" sane-find-scanner -v gives me:

...
searching for USB scanners:
checking /dev/usb/scanner... open ok, but vendor and product could NOT be identified
found USB scanner (UNKNOWN vendor and product) at device /dev/usb/scanner
....
  # Your USB scanner was detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.
  # `UNKNOWN vendor and product' means that there seems to be a scanner at this
  # device file but the vendor and product ids couldn't be identified.
  # Currently identification only works with Linux versions >= 2.4.8. You may
  # need to configure your backend manually, see the backend's manpage.

I feel I might have taken an important step forward, but I don't know what to do next? Is there a command to find out the product/device ID? And, if/when I find that, I guess there is a configuration file somewhere where I stick it?

UPDATE

Duh! I just noticed lsusb was giving me vendor ID (04f9) and product ID (0248). But I still don't know where to stick them. Thanks!

1

I have got the same problem as you; and although I do know what config file you need to insert vendor and product ID, I fear it will not be enough to get rid of the "Invalid Argument" error. (At least, I am still stuck with it.)

The file you want to edit is /lib/udev/rules.d/40-libsane.rules. Here, you need to insert the following line:

# Brother scanners
ATTRS{idVendor}=="04f9", ATTRS{idProduct}=="0248", ENV{libsane_matched}="yes"

(Actually, most tutorials I found so far content themselves with `ATTRS{idVendor}=="04f9", ENV{libsane_matched}="yes"'. Your posting here was the first time I've seen a product ID to try.)

My current status: After adding my own user account to the "lp" group, I am at least able to start xsane again. But on clicking the "scan" button, I only receive an "Invalid Argument" error message.

  • Thanks. Marked as correct, as I think that is the correct place to put the numbers. Still no change for me; sane-find-scanner -v set all failed to open; then I did the ln for /dev/usb/scanner to match what lsusb says, but I still get the exact same error ("vendor and product could NOT be identified"). :-( – Darren Cook Oct 6 '14 at 7:33
  • I feared as much. If you find a solution to the problem, please let me know. – Markus Gerwinski Oct 6 '14 at 12:24
0

USB Scanning Brother DCP-7055

  1. Download driver for scanning for this printer (32 bit or 64 bit, brascan-driver)
  2. Install via software center
  3. Edit 40-libsane rules
  4. Reboot (and pray?)

    1. 
    

    Find scanner Drivers for 32 bits or 64 bits here: http://support.brother.com/g/b/downloadlist.aspx?c=eu_ot&lang=en&prod=dcp7055_all&os=128

Download scanner drivers only, remember you have 32 bits and 64 bits, install via software center.

    2. 

start terminal copy this in order to open gedit sudo gedit /lib/udev/rules.d/40-libsane.rules

    3.

Gedit opens you want to insert this text

    # Brother scanners
    ATTRS{idVendor}=="04f9", ENV{libsane_matched}="yes"

The text should be insertet before this text: "# The following rule will disable ..."

    4. 

Reboot and pray.

PS: This editor is annoying i NEED to use asterix in plain text but it reformats the text and thus makes it incorrect, this for um is too difficult to use. Also numbered lists are automaticly used in a rather silly way.

PPS: I hope this is helpfull, I take no responsibility for errors typoes etc

  • Thanks Finn. Does scanning now work for you with the DCP-7055? I see there is a new scanner driver (Dec 12th 2014 release), so I will now try it again. (BTW, this site, and all the StackExchange family, use "markdown", which is very easy to pick up. Even some computer book publishers now have it as their preferred format, showing it has enough power and flexibility, too.) (I wasn't sure where you wanted to put an asterisk, so didn't edit your answer, but use backticks to escape code, and triple backticks for blocks of code.) – Darren Cook Jan 3 '15 at 15:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.