3

I'm running a fairly vanilla 14.04 Ubuntu on a newish HP desktop. Just yesterday I got the dreaded "Failed to download repository information":

screenshot

A screenshot of this window has been seen on AskUbuntu before. I have checked related threads here, and also looked at a helpful off-site article. The strange thing now is that when I run sudo apt-get update I get back E: Invalid operation update, so I can't even work out what the offending PPA is.

The Updater does find updates and apply them (you can see what I got today if you like), but that's little help in diagnosing the problem.

So my question: how do I fix this?!

2
  • I had the same error, I've missed apt command to run (e.g. install).
    – kenorb
    Oct 15 '15 at 21:36
  • I've ended up here three times already when my shell script ends up having CRLF line endings instead LF line endings. Future self, just switch the line endings. Aug 1 '17 at 19:20
4

Usually this error happens when you mis-type the apt command, which doesn't seem to be case here (if I believe you).

Can you please login as su and then do the apt-get update?

I know using the system as Super User is not a good thing to do but at lease for one time, you can give it a try.

P.S. Is there a proxy on your network?

1
  • Finally had a chance to look at this - updating as "su" did the trick: I could identify the offending PPA's. I used the sudo -i temporary "su" login as described in the RootSudo documentation. Nice to have that sorted! :)
    – Dɑvïd
    Sep 18 '14 at 10:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.