1

I recently installed 14.04, and my date/time display is unnecessarily localized. Upon installation, I chose Colombo as my location:

location

Now the date/time is displayed in localized form (Sinhala language). I don't remember choosing a language any other than English (US).

top panel enter image description here

How do I revert this to show date/time display in English (US)?

Edit: Executing locale on console produces following:

LANG=en_US.UTF-8
LANGUAGE=en_US
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC=si_LK
LC_TIME=si_LK
LC_COLLATE="en_US.UTF-8"
LC_MONETARY=si_LK
LC_MESSAGES="en_US.UTF-8"
LC_PAPER=si_LK
LC_NAME=si_LK
LC_ADDRESS=si_LK
LC_TELEPHONE=si_LK
LC_MEASUREMENT=si_LK
LC_IDENTIFICATION=si_LK
LC_ALL=
  • Type locale to see what is set by default. – cuonglm Sep 9 '14 at 1:49
  • @Gnouc: I can see that several LC_* variables are set to si_LK. Added info to the question. – sampathsris Sep 9 '14 at 14:35
4

Go to System settings and select Language Support app then do the steps like in screen shot:

enter image description here

Then restart the system for the change to take effect.

| improve this answer | |
  • 2
    Thanks, this works, but restart is required. – sampathsris Sep 9 '14 at 14:54
1

LC_TIME=si_LK affects your time output. Try:

LC_TIME=en_us ls -l

To make permanent changes, edit your /etc/default/locale.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.