0
d@d-Satellite-C655:~$ df -h
Filesystem        Size  Used Avail Use% Mounted on
/dev/sda7          38G   36G  278M 100% /
none              4.0K     0  4.0K   0% /sys/fs/cgroup
udev              931M  4.0K  931M   1% /dev
tmpfs             189M  1.1M  188M   1% /run
none              5.0M     0  5.0M   0% /run/lock
none              943M  1.4M  942M   1% /run/shm
none              100M   20K  100M   1% /run/user
overflow          1.0M  1.0M     0 100% /tmp
/home/d/.Private   38G   36G  278M 100% /home/d

It appears i've used 100% of /dev/sda7,does anyone know how i might go about cleaning it up or emptying it out, being that, since learning this, i've restarted my computer, and am now unable to log into the administrator account shown above. since then i've successfully logged into the guest account and:

guest-ihp062@d-Satellite-C655:~$ sudo chmod 755 /dev/sda7 -R
sudo: unable to change to sudoers gid: Operation not permitted
guest-ihp062@d-Satellite-C655:~$ sudo apt-get autoclean
sudo: unable to change to sudoers gid: Operation not permitted

guest-ihp062@d-Satellite-C655:~$ login d
login: Cannot possibly work without effective root
guest-ihp062@d-Satellite-C655:~$ sudo passwd root
sudo: unable to change to sudoers gid: Operation not permitted

What am i missing?

  • You have 278Mb available on that partition, and that's to a normal user (the root user has reserved space, so would see even more space). It is not full, and shouldn't prevent you booting. If you're having trouble logging in, that is likely a separate problem. That said, you should do something about the disk being that full, as it's likely to become a problem later. – thomasrutter Sep 9 '14 at 0:30
1

You should be able to boot into recovery mode. This is a special mode where you log in as root, have only a terminal, and start with read-only access to the drive (which you can then convert to read-write access).

Follow the instructions here:

https://wiki.ubuntu.com/RecoveryMode

In particular, press and hold Shift when Ubuntu is booting, select Recovery mode from Advanced Options, then when prompted, Drop to root shell prompt.

You enable read/write access to the drive with mount -o remount,rw /

0

Test this:

Press and hold Shift when Ubuntu is booting

Select Recovery mode from Advanced Options

Select from Submenu

fsck
clean
root

In a terminal.

Run it:

dpkg --purge `COLUMNS=300 dpkg -l | egrep "^rc" | cut -d' ' -f3`
apt-get autoremove
apt-get clean
  • Result: SELECTED FSCK OPTION. Continuing will remount your / filesystem in read/write mode and.../ect/fstab. ...continue? <Yes> fsck from util-linux 2.20.1 /dev/sda7: Superblock last mount time is in the future. (by less than a day, probably due to the hardware clock being incorrectly set). FIXED. /dev/sda7: Superblock last write time is in the future. (by less than a day, probably due to the hardware clock being incorrectly set). FIXED. /dev/sda7: 361861/2501856 files (0.3% non-contiguous), 9518650/10001664 blocks – slack Sep 9 '14 at 22:21
  • CTRL+ALT+DEL TO RECOVERY MENU, SELECTED CLEAN OPTION. Continuing will remount your / filesystem in read/write mode...etc. ...continue? <Yes> HELD DOWN POWER BUTTON TO RESTART AFTER NO APPARENT RESULT. – slack Sep 9 '14 at 22:36
  • BACK TO RECOVERY MODE, CHOSE ROOT OPTION. root@d-Sattelite-C655:~# dpkg --purge 'COLUMNS=300 dpkg -l | egrep "^rc" | cut -d' '-f3` > apt-get autoremove > apt-get clean dpkg: error: unable to access dpkg status area: Read-only file system W: Not using locking for read only lock file /var/lib/dpkg/ E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem W: Not using locking for read only lock file /var/cache/apt/archives/lock – slack Sep 9 '14 at 22:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.