13

Please notice the three updates at the end of the post.

Original problem

I installed Lubuntu 14.04.1 on an older Acer Travelmate 4500 using the forcepae option and adjusting upowerd.py according to https://askubuntu.com/a/515909/288322. After running the update manager until the system is said to be up-to-date, I have two problems: I cannot access USB memory sticks and the laptop hangs during shut-down.

The problem might somehow be connected to the update packages "common library libudev" and "/dev/ and hotplug background process": I selected one update at a time; when selecting "common library libudev" as the second last (I wanted to select "/dev/ and hotplug background process" as the last one), the update hung at that moment the status bar showed Setting up udev (204-5ubuntu20.5). Some lines before that, it said Adding diversion of /bin/udevadm to /bin/udevadm.upgrade by fake-udev'; that might also be of interest. Other than that it was the usual preparing to unpack, unpacking, processing and setting up "libudev1:i386 (204-5ubuntu20.5)". I had to kill the update manager and to re-start the laptop.

Now, i.e. after re-boot, I can access USB memory sticks and the system shut-down work excellent (showing All processes ended within 1 seconds..., a message about NetworkManager[471] , Deactivating swap and Will now halt and then, shutting off. So far so good, but the wireless was not working; there was no eth1 listed in iwconfig. I re-booted but it continued as described (USB perfect, shut-down perfect, no wireless). At that stage, I posted a description in the question https://askubuntu.com/q/521402/288322 (perhaps that description could help, even though I closed that question.)

Then, I opened the update manager again and it automatically run some tasks and showing the message that the system is now up-to-date. There were no more updates available, i.e. the "/dev/ and hotplug background process" which I did not yet choose to install must have been installed automatically. USB and shut-down worked, wireless not.

Then, after re-starting, this changed: Now, I...

  • ...cannot access any USB memory sticks;
  • ...the system hangs at shut-down showing Killing all remaining processes ... [fail], a message on NetworkManager and Will now halt but never shutting down;
  • ...wireless eth1 works fine.

Regarding hang-up during shut-down, I described a slightly earlier stage (still valid, but details might have changed marginally) in a question on Lubuntu: neither shut-down nor restart works.

Regarding USB sticks, I read USB recognized but not available?. Here, similar information:

luke@humboldt:~$ uname -a
Linux humboldt 3.13.0-35-generic #62-Ubuntu SMP Fri Aug 15 01:58:01 UTC 2014 i686 i686 i686 GNU/Linux

Before entering any USB devices:

luke@humboldt:~$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

After entering two USB devices (one memory stick and one external hard disk which both work fine on another computer):

luke@humboldt:~$ lsusb
Bus 001 Device 005: ID 8644:800b  
Bus 001 Device 006: ID 1058:0910 Western Digital Technologies, Inc. MyBook Essential External HDD
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

However, none of the USB devices is accessible in PCManFM and also not listed under /media/luke.

With both USB devices still connected fdisk shows:

luke@humboldt:~$ sudo fdisk -l
Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 Köpfe, 63 Sektoren/Spur, 9729 Zylinder, zusammen 156301488 Sektoren
Einheiten = Sektoren von 1 × 512 = 512 Bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Festplattenidentifikation: 0x000e9d19

   Gerät  boot.     Anfang        Ende     Blöcke   Id  System
/dev/sda1   *        2048    19533297     9765625   83  Linux
/dev/sda2        19533822   156301311    68383745    5  Erweiterte
/dev/sda5       153718784   156301311     1291264   82  Linux Swap / Solaris
/dev/sda6        19533824   153718783    67092480   83  Linux

Partitionstabelleneinträge sind nicht in Platten-Reihenfolge

And lsblk shows the same with the USB devices connected:

NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0  74,5G  0 disk 
├─sda1   8:1    0   9,3G  0 part /
├─sda2   8:2    0     1K  0 part 
├─sda5   8:5    0   1,2G  0 part [SWAP]
└─sda6   8:6    0    64G  0 part 
sr0     11:0    1  1024M  0 rom 

GParted does also only show the same four partitions. And also Disk Utility does not show the USB memories.

dmesg shows:

[ 1076.648283] usb 1-4: new high-speed USB device number 5 using ehci-pci
[ 1076.780965] usb 1-4: New USB device found, idVendor=8644, idProduct=800b
[ 1076.780978] usb 1-4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 1076.780987] usb 1-4: Product: USB Flash Disk                
[ 1076.780996] usb 1-4: Manufacturer: General                       
[ 1076.781005] usb 1-4: SerialNumber: 00000000000010D7
[ 1080.492276] usb 1-3: new high-speed USB device number 6 using ehci-pci
[ 1080.625435] usb 1-3: New USB device found, idVendor=1058, idProduct=0910
[ 1080.625447] usb 1-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 1080.625457] usb 1-3: Product: External HDD    
[ 1080.625465] usb 1-3: Manufacturer: Western Digital 
[ 1080.625474] usb 1-3: SerialNumber: 5743414E5933333530363735

I re-booted the laptop several times; the problem persists. When using a Lubuntu 14.04.1 live-CD, all devices are directly accessible.

Could this problem be related to udev? Because between restarting after the failed first update and before re-running the update manager once more, I could access USB devices as well as shut-down the system properly. But, wifi/eth1 was missing. I put the whole syslog on https://www.dropbox.com/sh/b1ghdxsq1x1v7wv/AAD05PcvzIY33SpbcsXoK0QKa?dl=0 in case that might help. I also added kern.log, apt/history.log, apt/term.log, installer/syslog, installer/debug and the output of lspci -nn and demidecode.

There was also a comment that the kernel might not mapp correctly to sd*, see USB recognized but not available?.

Thanks for some hints in advance!

Update 1

By chance, I found that a USB stick that is already connected before switching on the laptop is accessible.

Now, lsusb shows:

Bus 001 Device 002: ID 8644:800b  
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

And 'fdisk -l`:

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 Köpfe, 63 Sektoren/Spur, 9729 Zylinder, zusammen 156301488 Sektoren
Einheiten = Sektoren von 1 × 512 = 512 Bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Festplattenidentifikation: 0x000e9d19

   Gerät  boot.     Anfang        Ende     Blöcke   Id  System
/dev/sda1   *        2048    19533297     9765625   83  Linux
/dev/sda2        19533822   156301311    68383745    5  Erweiterte
/dev/sda5       153718784   156301311     1291264   82  Linux Swap / Solaris
/dev/sda6        19533824   153718783    67092480   83  Linux

Partitionstabelleneinträge sind nicht in Platten-Reihenfolge

Platte /dev/sdb: 2003 MByte, 2003828736 Byte
62 Köpfe, 62 Sektoren/Spur, 1018 Zylinder, zusammen 3913728 Sektoren
Einheiten = Sektoren von 1 × 512 = 512 Bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Festplattenidentifikation: 0x00005b5c

   Gerät  boot.     Anfang        Ende     Blöcke   Id  System
/dev/sdb1              62     3913191     1956565    b  W95 FAT32

And lsblk:

NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0  74,5G  0 disk 
├─sda1   8:1    0   9,3G  0 part /
├─sda2   8:2    0     1K  0 part 
├─sda5   8:5    0   1,2G  0 part [SWAP]
└─sda6   8:6    0    64G  0 part 
sdb      8:16   1   1,9G  0 disk 
└─sdb1   8:17   1   1,9G  0 part /media/luke/9369-1C8B
sr0     11:0    1  1024M  0 rom  

And finally dmesg | grep usb:

[    0.099144] usbcore: registered new interface driver usbfs
[    0.099163] usbcore: registered new interface driver hub
[    0.099198] usbcore: registered new device driver usb
[    1.048135] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
[    1.048140] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    1.048144] usb usb1: Product: EHCI Host Controller
[    1.048148] usb usb1: Manufacturer: Linux 3.13.0-35-generic ehci_hcd
[    1.048151] usb usb1: SerialNumber: 0000:00:1d.7
[    1.048889] usb usb2: New USB device found, idVendor=1d6b, idProduct=0001
[    1.048894] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    1.048897] usb usb2: Product: UHCI Host Controller
[    1.048901] usb usb2: Manufacturer: Linux 3.13.0-35-generic uhci_hcd
[    1.048905] usb usb2: SerialNumber: 0000:00:1d.0
[    1.049437] usb usb3: New USB device found, idVendor=1d6b, idProduct=0001
[    1.049441] usb usb3: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    1.049445] usb usb3: Product: UHCI Host Controller
[    1.049448] usb usb3: Manufacturer: Linux 3.13.0-35-generic uhci_hcd
[    1.049452] usb usb3: SerialNumber: 0000:00:1d.1
[    1.049969] usb usb4: New USB device found, idVendor=1d6b, idProduct=0001
[    1.049973] usb usb4: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    1.049977] usb usb4: Product: UHCI Host Controller
[    1.049981] usb usb4: Manufacturer: Linux 3.13.0-35-generic uhci_hcd
[    1.049984] usb usb4: SerialNumber: 0000:00:1d.2
[    1.416097] usb 1-6: new high-speed USB device number 2 using ehci-pci
[    1.560837] usb 1-6: New USB device found, idVendor=8644, idProduct=800b
[    1.560842] usb 1-6: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    1.560846] usb 1-6: Product: USB Flash Disk                
[    1.560850] usb 1-6: Manufacturer: General                       
[    1.560853] usb 1-6: SerialNumber: 00000000000010D7
[    1.662608] usb-storage 1-6:1.0: USB Mass Storage device detected
[    1.662848] scsi2 : usb-storage 1-6:1.0
[    1.663257] usbcore: registered new interface driver usb-storage

However, once I removed the USB stick (by clicking on the unmount icon in PCManFM and unplugging the stick) and inserted again, it is no longer accessible. The entry in PCManFM is still there, but when clicking on it, it says Error mounting /dev/sdb1 at /media/luke/9369-1C8B: Command-line 'mount -t "vfat" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,shortname=mixed,dmask=0077,utf8=1,showexec,flush" "/dev/sdb1" "/media/luke/9369-1C8B"' exited with non-zero exit status 32: mount: special device /dev/sdb1 does not exist.

In dmesg | grep usb the following new lines appear:

[  724.977853] usb 1-6: USB disconnect, device number 2
[  729.652276] usb 1-6: new high-speed USB device number 3 using ehci-pci
[  729.784976] usb 1-6: New USB device found, idVendor=8644, idProduct=800b
[  729.784988] usb 1-6: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  729.784998] usb 1-6: Product: USB Flash Disk                
[  729.785007] usb 1-6: Manufacturer: General                       
[  729.785016] usb 1-6: SerialNumber: 00000000000010D7
[  729.785593] usb-storage 1-6:1.0: USB Mass Storage device detected
[  729.785733] scsi3 : usb-storage 1-6:1.0

The output of lsusb , fdisk -l and lsblk are still looking the same as above (in section update).

If I, now, connect a second USB stick (i.e. two are connected), that one is accessible in PCManFM using the menu entry of the very first stick. If I ,then, insert a third one (i.e. three are connected), I cannot access it because there is still only one entry (the very first one) in PCManFM which leads to the second USB stick.

Now (i.e. with three sticks), lsblk shows:

sda      8:0    0  74,5G  0 disk 
├─sda1   8:1    0   9,3G  0 part /
├─sda2   8:2    0     1K  0 part 
├─sda5   8:5    0   1,2G  0 part [SWAP]
└─sda6   8:6    0    64G  0 part /media/luke/61314bd4-8148-493a-9812-38a73af8bb8
sdb      8:16   1 983,8M  0 disk 
└─sdb1   8:17   1 983,8M  0 part /media/luke/9369-1C8B
sdc      8:32   1   1,9G  0 disk 
└─sdc1   8:33   1   1,9G  0 part 
sdd      8:48   1   1,9G  0 disk 
└─sdd1   8:49   1   1,9G  0 part 
sr0     11:0    1  1024M  0 rom 

Thanks for hints & help!

Update 2

Now, I installed Debian 7 (Wheezy) where I got some other/more information/error messages to (parts of) the same problem. During normal start-up, the message

'udevd[384]: timeout: killing '/sbin/modprobe -b acpi:ACPI0002:' [466]'

appeared a hundred times, followed by

udevadm settle - timeout of 120 seconds reached, the event queue contains:
/sys/devices/LNSYSTM:00/LNXSYBUS:00/ONP0A03:00/device:09/PNP0C09:00/ACPI0001:00/ACPI0002:00 (719)
/sys/devices/LNSYSTM:00/LNXSYBUS:00/ONP0A03:00/device:09/PNP0C09:00/ACPI0001:00/ACPI0002:00/power_supply/sbs-charger (972)
/sys/devices/LNSYSTM:00/LNXSYBUS:00/ONP0A03:00/device:09/PNP0C09:00/ACPI0001:00/ACPI0002:00/power_supply/sbs-charger (973)
/sys/devices/LNSYSTM:00/LNXSYBUS:00/ONP0A03:00/device:09/PNP0C09:00/ACPI0001:00/ACPI0002:00/power_supply/BTA0 (1105)
/sys/devices/LNSYSTM:00/LNXSYBUS:00/ONP0A03:00/device:09/PNP0C09:00/ACPI0001:00/ACPI0002:00/power_supply/BTA0 (1106)

After that, start-up continued as it should.

Also /var/log/syslog is full of entries of

'udevd[384]: timeout: killing '/sbin/modprobe -b acpi:ACPI0002:' [466]' 

and includes once per start-up also

Sep 27 10:36:37 humboldt kernel: [  960.684082] INFO: task kworker/0:3:481 blocked for more than 120 seconds.
Sep 27 10:36:37 humboldt kernel: [  960.684093] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
Sep 27 10:36:37 humboldt kernel: [  960.684102] kworker/0:3     D f31b9265     0   481      2 0x00000000
Sep 27 10:36:37 humboldt kernel: [  960.684115]  f72ce810 00000046 c101de72 f31b9265 00000002 f72ce810 f72c3f50 f72c3f3c
Sep 27 10:36:37 humboldt kernel: [  960.684133]  c1285024 c1284eec c116cbb8 f72c3f0c f5c70518 fffee575 f72ce810 c139cc6c
Sep 27 10:36:37 humboldt kernel: [  960.684150]  f5f6005c f5f60064 c139cc2c c101b544 f72ce810 f5c70500 f72c3f63 f7186a44
Sep 27 10:36:37 humboldt kernel: [  960.684167] Call Trace:
Sep 27 10:36:37 humboldt kernel: [  960.684185]  [<c101de72>] ? try_to_wake_up+0x78/0x80
Sep 27 10:36:37 humboldt kernel: [  960.684200]  [<c1285024>] ? __mutex_unlock_slowpath+0x18/0x19
Sep 27 10:36:37 humboldt kernel: [  960.684211]  [<c1284eec>] ? mutex_unlock+0x9/0xa
Sep 27 10:36:37 humboldt kernel: [  960.684225]  [<c116cbb8>] ? acpi_ec_transaction+0x1df/0x202
Sep 27 10:36:37 humboldt kernel: [  960.684236]  [<c101b544>] ? set_next_entity+0x29/0x51
Sep 27 10:36:37 humboldt kernel: [  960.684248]  [<c1284f8c>] ? __mutex_lock_common.isra.7+0x76/0xae
Sep 27 10:36:37 humboldt kernel: [  960.684260]  [<c1284f14>] ? mutex_lock+0x13/0x15
Sep 27 10:36:37 humboldt kernel: [  960.684289]  [<f80fe1fc>] ? smbus_alarm+0x4a/0xa4 [sbshc]
Sep 27 10:36:37 humboldt kernel: [  960.684309]  [<c116c5ae>] ? acpi_ec_run+0x13/0x32
Sep 27 10:36:37 humboldt kernel: [  960.684319]  [<c11685b7>] ? acpi_os_execute_deferred+0x1a/0x23
Sep 27 10:36:37 humboldt kernel: [  960.684333]  [<c10331db>] ? process_one_work+0x113/0x1eb
Sep 27 10:36:37 humboldt kernel: [  960.684344]  [<c1033b1a>] ? worker_thread+0xa3/0x11a
Sep 27 10:36:37 humboldt kernel: [  960.684355]  [<c1033a77>] ? manage_workers.isra.34+0x1a8/0x1a8
Sep 27 10:36:37 humboldt kernel: [  960.684365]  [<c1035fba>] ? kthread+0x62/0x67
Sep 27 10:36:37 humboldt kernel: [  960.684376]  [<c1035f58>] ? flush_kthread_worker+0x73/0x73
Sep 27 10:36:37 humboldt kernel: [  960.684389]  [<c1289ac6>] ? kernel_thread_helper+0x6/0xd

The good news is that all these error massages - and the delay the errors caused during start-up and shut-down - could avoided be blacklisting the kernel module 'sbs' (adding sbs.blacklist=yes after ... quiet splash in Grub) which is related to Smart Battery System used in my laptop. With this adjustment, everything works fine on Debian.

I hope, this can help somebody to adjust Lubuntu in order to be make it also working on other old laptops.

Thanks!

Update 3

Now, I installed Lubuntu 14.04.2 using the forcepae option and adjusting upowerd.py according to https://askubuntu.com/a/515909/288322. The good news is that USB sticks can be accessed without problems.

However, the problems at shut-down are still existing. It says:

wait-for-state stop/waiting
* Stopping rsync daemon rsync                                         [OK]
* Asking all remaining processes to terminate…                        [OK]
* Killing all remaining processes…                                    [fail]
nm-dispatcher.action: Caught signal 15, shutting down...
* Deactivating swap…                                                  [OK]
* Will now halt
[ 360.064265] INFO: task upowerd:1473 block for more than 120 seconds.
[ 360.064441]       Tainted: G S            3.16.0-34-generic #47"14.04.1-Ubuntu
[ 360.064620] "echo 0 > /proc/sys/kernel/hung_tasks_timeout_secs" disables this message.
[ 480.065143] INFO: task halt:2588 block for more than 120 seconds.
[ 480.065302]       Tainted: G S            3.16.0-34-generic #47"14.04.1-Ubuntu
[ 480.065481] "echo 0 > /proc/sys/kernel/hung_tasks_timeout_secs" disables this message.

These messages are then repeated again and again. (There is no difference whether one blacklists the kernel module sbs or not.)

Thanks for hints & help!

6
  • 1
    Possible duplicate: askubuntu.com/questions/522515/… – Elder Geek Jan 2 '15 at 15:25
  • 1
    eth is ethernet and not wireless, iwconfig should show wlan0 or wlan1 etc. for wireless devices and not eth1 – mchid Jan 10 '15 at 12:54
  • the output says you can skip 120 seconds wait by running echo "0" | sudo tee /proc/sys/kernel/hung_task_timeout_secs – mchid Mar 15 '15 at 13:41
  • 1
    Note that now that your issue is on Debian 8 and NOT Ubuntu, this question is likely offtopic. If you are saying that this needs to be fixed in Ubuntu/Lubuntu, file a bug. – Thomas Ward Mar 16 '15 at 17:52
  • 1
    I'm voting to close this question as off-topic because Although it starts off being about Ubuntu it ends up about Debian. It's unlikely to help future users and is currently off-topic as written. – Elder Geek Mar 16 '15 at 21:50
1

Since you are using a single core processor, I believe you should NOT be using the forcepae option.

The standard Lubuntu installation uses a non-pae kernel and pentimum M processors ARE pae capable, however, the non-pae kernel is also a non-SMP kernel. Having an SMP kernel on a single core system will slow you down, hence you have the error for "Tainted: G S" here Installing Lubuntu 14.04.1 fails, upowerd appears to hang.

G = all modules are GPL licenced (no big deal)

S = occurred on an SMP kernel running on hardware that hasn't been certified as safe to run multiprocessor

https://wiki.ubuntu.com/DebuggingKernelOops

if you do not have multiple processors, the additional code in an SMP kernel will only slow you down

https://help.ubuntu.com/community/Kernel#SMP

The problem with a pae kernel on a pentimu m processor is not pae capability, it's the fact that a single core processor shouldn't run on a kernel that is SMP.

4
  • Thanks for your explanations! As I understood, Lubuntu dropped support for non-PAE processors; therefore, I installed it with the forcepae option. Is it possible to use Lubuntu with a kind of "non-SMP option"? – Rantanplan Apr 17 '15 at 17:06
  • @Rantanplan I believe non-pae is still available for Lubuntu, just don't do forcepae and use i386 or other non amd64 basic option. – mchid Apr 21 '15 at 17:00
  • According to wiki.ubuntu.com/Lubuntu/AdvancedMethods#Processor_.28CPU.29 it seems that one needs to have PAE. Trying to install without forecepae option yields the error message: Kernel requires features not present on the CPU: PAE. – Rantanplan Apr 22 '15 at 11:37
  • According to: help.ubuntu.com/community/… the instructions for installing non-pae can be found here: help.ubuntu.com/community/… – mchid Apr 22 '15 at 13:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.