1

Just recently (late August / early September 2014) my multiple monitor setup and Nvidia optimus is not working. I had the symptoms characterized by this bug. After setting the BIOS to graphics card: integrated and Optimus: disabled, I was able to start Ubuntu, but it would not detect my external monitor. Then I uninstalled and re-installed Nvidia Primus. Then I tried both suggestions in the bug tracker, involving:

sudo apt-get install ubuntu-drivers-common=1:0.2.91.4

and

sudo dpkg -i ubuntu-drivers-common_0.2.91.5_amd64.deb nvidia-common_0.2.91.5_amd64.deb 

(after downloading the associated .deb's), rebooted, and reset the BIOS to graphics card: Optimus and Optimus: enabled, but I cannot detect the external monitor. Am I missing something, or are there any suggestions on how to proceed?

I am running Ubuntu 14.04 on a Lenovo W520.

UPDATE

Now that a fix has been released on ubuntu-drivers-common, any suggestions on how to proceed? I am a bit skeptical because not all of the packages have been fixed, and the Trusty description under ubuntu-drivers-common says Triaged. Is it okay to remove the hold from the packages described below, and is there anything else I should do?

A little explanation about the meaning of the bug's status would also be helpful. My interpretation is that a fix has been released for ubuntu-drivers-common, and it is a workaround for the moment, because none of the other packages are fixed. Is that correct?

3

I'm the OP of the askubuntu question linked in the bug.

It's hard to tell how I got it to work, but my recommendation would be:

sudo dpkg -i ubuntu-drivers-common_0.2.91.5_amd64.deb nvidia-common_0.2.91.5_amd64.deb
sudo apt-mark hold ubuntu-drivers-common
sudo apt-mark hold nvidia-common
sudo apt-get purge nvidia* bumblebee*
sudo apt-get install nvidia-331-updates nvidia-settings nvidia-prime

In other words, after the downgrade just reinstall the nvidia driver completely. Of course, feel free to replace nvidia-331-updates with the version of your choice. For me, this seems to have worked and my external screen is working as well.

Edit: Just now saw your comment that you resolved the issue. Please post that explanation in the bug report as well as it may provide useful information.

Edit #2: Glad to see that your solution is what I had suggested as well. I guess we can say this has proven to be a working workaround to downgrade.

  • Thanks for the response @Ingo ! One last question: since this is a workaround, do you have any suggestions moving forward with the issue? I plan to keep an eye on the bug tracker, and when it is fixed, I will remove the hold on nvidia-common and ubuntu-drivers-common. Is there anything else I should do? – modulitos Sep 8 '14 at 6:11
  • @Lucas I'm not aware of anything else to do. For me this is working without any problems so I'll probably just have to wait for the fix. Before the upgrade is after the upgrade. Are you experiencing any issues still? – Ingo Bürk Sep 8 '14 at 6:40
  • Nope, I don't have an issue anymore, but I would like to keep it that way. I was just checking to avoid any future Optimus issues. Judging from past experience with Optimus, there will be more issues to come :) – modulitos Sep 8 '14 at 6:45
  • @Lucas Yeah, I'm sure more issues will come up. :) But for now it's working and if the fix in ubuntu-drivers-common doesn't work we still know how to downgrade. ;) – Ingo Bürk Sep 8 '14 at 15:14
  • were you able to resolve the issue with the new bug fix? I tried the new fix by removing the hold and performing and update/upgrade, but xrandr does not detect my external VGA monitor. Any help is appreciated, and more details are in my post here: askubuntu.com/questions/550750/… – modulitos Nov 20 '14 at 18:32
0

First, check that your drivers are up to date running sudo apt-get update && apt-get upgrade. If this does not help, you can manually test the drivers in System settings -> Additional drivers. There, you should see a list of video drivers, both open source and closed source. Try with them to see which one works. Sometimes the closed source one is better or more stable. At least that is the case for me with a fairly new ATI card.

If none of these drivers solve your issue, then it might be an indication of a bug, in which case your right forum is Launchpad. You can post here any advance done there as this will make this question useful for other users too.

  • Thanks for the tip. Under Additional Drivers I have 5 drivers listed, but judging from previous experience, I am fairly certain that none of these work. I continued investigating the LaunchPad issue linked above, and I resolved the issue. I will try to explain it as an answer below. – modulitos Sep 8 '14 at 5:49
  • There is a regression bug since few days: bugs.launchpad.net/ubuntu/+source/ubuntu-drivers-common/+bug/… – fcole90 Sep 8 '14 at 8:01
0

Using information from the LaunchPad link above and this link on installing/re-installing Nvidia Primus, I was able to re-implement my external monitors. This answer is not a permanent solution, but rather a detailing of the workaround that was suggested in the LaunchPad issue.

Basically, I did the following:

Purged existing Nvidia drivers/Optimus-related packages:

sudo apt-get purge libvdpau-va-gl1 bumblebee* nvidia*

Re-installed the same:

sudo apt-get install nvidia-331 nvidia-settings nvidia-prime

Downloaded and installed the temporary (workaround) downgraded packages:

sudo dpkg -i ubuntu-drivers-common_0.2.91.5_amd64.deb nvidia-common_0.2.91.5_amd64.deb 

Rebooted, set my BIOS to graphics card: Optimus and Optimus: enabled, and everything was back to normal. I was able to detect my external monitor. Note that I still cannot use my laptop monitor and my external monitor together since switching from Bumblebee to Primus, but at least I have access to my external monitor again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.