0

My USB pen (Kingston 16GB) is not detecting in the system (Ubuntu 12.10 or Windows). I tried followings but no any luck. Could any one give an idea to try... I want it with / without current data on it.

It is displaying for lsusb

namal@namal:~$ lsusb 
Bus 002 Device 017: ID 0951:1642 Kingston Technology DT101 G2

It says "Disk /dev/sdc doesn't contain a valid partition table" for fdisk -l

namal@namal:~$ sudo fdisk -l
Disk /dev/sdc: 15.5 GB, 15479597056 bytes
64 heads, 32 sectors/track, 14762 cylinders, total 30233588 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x2abd9350

Disk /dev/sdc doesn't contain a valid partition table

Then I tried to create some partitions as follows. But failed with Error closing file when writing the partition.

namal@namal:~$ sudo fdisk /dev/sdc
Device contains neither a valid DOS partition table, nor Sun, SGI or OSF disklabel
Building a new DOS disklabel with disk identifier 0x1683c1c4.
Changes will remain in memory only, until you decide to write them.
After that, of course, the previous content won't be recoverable.

Warning: invalid flag 0x0000 of partition table 4 will be corrected by w(rite)

Command (m for help): n
Partition type:
   p   primary (0 primary, 0 extended, 4 free)
   e   extended
Select (default p): p
Partition number (1-4, default 1): 
Using default value 1
First sector (2048-30233587, default 2048): 
Using default value 2048
Last sector, +sectors or +size{K,M,G} (2048-30233587, default 30233587): 
Using default value 30233587

Command (m for help): w
The partition table has been altered!

Calling ioctl() to re-read partition table.

Error closing file

I tried to write some zeros to there and it is succeeded.

namal@namal:~$ sudo dd if=/dev/zero of=/dev/sdc bs=512 count=1
1+0 records in
1+0 records out
512 bytes (512 B) copied, 39.2583 s, 0.0 kB/s

Tried some fsck commands as well.

namal@namal:~$ sudo  fsck /dev/sdc
fsck from util-linux 2.20.1
e2fsck 1.42.5 (29-Jul-2012)
ext2fs_open2: Bad magic number in super-block
fsck.ext2: Superblock invalid, trying backup blocks...
fsck.ext2: Bad magic number in super-block while trying to open /dev/sdc

The superblock could not be read or does not describe a correct ext2
filesystem.  If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device&gt;

namal@namal:~$ sudo e2fsck -b 8193 /dev/sdc
e2fsck 1.42.5 (29-Jul-2012)
e2fsck: Attempt to read block from filesystem resulted in short read while trying to open /dev/sdc
Could this be a zero-length partition?

I tried to format it using FAT32. It hangs for so long but no results. NTFS asking for partitions.

sudo mkfs.vfat -n 'Asiri' -I /dev/sdc

This is how it looks like in GParted. Now I'm trying Devices > Create a new partition table. It throws IO error... enter image description here

Result :An IO Error..

enter image description here

1

You can't fsck something that doesn't have a filesystem or even a partition, formatting won't work either.

You say it's not recognized in Windows either, probably a hardware failure.

  • Yep I also thought so. But "sudo dd if=/dev/zero of=/dev/sdc bs=512 count=1" was succeeded.. – namalfernandolk Sep 7 '14 at 21:50
  • That probably works because you write to the raw device... – Jan Sep 7 '14 at 21:51
  • If it wrote correctly to the raw device it couldn't be a hardware failure right? – namalfernandolk Sep 7 '14 at 21:53
  • Hard to tell, if the controller is flaky then all kind of stuff can happen. – Jan Sep 7 '14 at 21:54
  • Hmmm... Do you have any idea to try? Or is it looks like I need to try for a new pen drive? – namalfernandolk Sep 7 '14 at 21:55

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.