3

I'm trying to connect to my Windows Share from Ubuntu, and I can't access it although I can access my Users folder. The share works fine when I'm connecting from a Windows computer, so the problem lies between Ubuntu and Windows.

Here's an overview of what happens when I'm using smbclient -L 192.168.1.201

Domain=[TICK-PC] OS=[Windows 8.1 Pro 9600] Server=[Windows 8.1 Pro 6.3]

Sharename       Type      Comment
 ---------       ----      -------
 ADMIN$          Disk      Administration à distance
 C$              Disk      Partage par défaut
 E$              Disk      Partage par défaut
 F$              Disk      Partage par défaut
 IPC$            IPC       IPC distant
 Media           Disk      
 print$          Disk      Pilotes d’imprimantes
 Users           Disk      
 Connection to 192.168.1.201 failed (Error NT_STATUS_RESOURCE_NAME_NOT_FOUND)
 NetBIOS over TCP disabled -- no workgroup available

I tried to force the activation of NetBIOS over TCP, but it didn't fix it. I tried uninstalling Windows Live Sign in ID Assistant, it didn't fix it.

sudo mount -t cifs //192.168.1.201/Media /mnt/Media -o username=tick

didn't work either :

mount error(5): Input/output error Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

I'm at a loss atm any help please ?

Edit : I found out that I can share folders on my SDD and internal hard drive just fine, so the problem lies with the external HD.

  • 1
    As a nit-pick, mounting using "cifs" is using package "cifs-utils" not "samba". You don't even need Samba installed to use cifs mountpoints. I use cifs shares without Samba and no issues at all, just specify IP addresses and not names (names come from winbind anyway). – headkase Sep 8 '14 at 1:37
2

Ok I finally fixed it the usb port on which the external hard drive was plugged somehow blocked the share when I was trying to access it from Linux even though it caused no problem when I was trying to access it from Windows.

Anyway I switched ports and everything is fine now.

  • I just had this exact problem, you saved my life, couldn't go to bed until I fixed this! – Kik Oct 10 '16 at 6:26
0

Test this:

sudo mount -t cifs -o username=tick,sec=ntlm //192.168.1.201/Media /mnt/Media 
  • I already tried to lower the encryption to ntlm, it didn't work :/. This is a strange problem. After further testing, it appears that it's only this particular external HD that has a problem. – jocelynthode Sep 8 '14 at 9:31
0

Just to make sure have you created the folder /mnt/Media? Btw, there is a similar case here, might be good to check out: http://ubuntuforums.org/archive/index.php/t-1607610.html

Read the last few threads, he solved it by uninstalling Microsoft Live Essential. You may also want to check if you have NETBIOS turn on at windows pc, and there is no firewall blocking access from network to your external HDD.

  • Yes /mnt/Media was created, but I understand why you asked this :). The guy on the link you provided doesn't seem to have the same problem as me. As I said in my post, I already uninstalled Microsoft Live and turned NetBIOS on by default. This didn't fix it. I've checked my firewall already but a second can't hurt. – jocelynthode Sep 8 '14 at 9:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.