1

When I try to install anything, I get an error.

ex:

diego@diego-Satellite-C655:~$ sudo apt-get install spotify-client
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  libgconf2-4
Recommended packages:
  libavcodec53 libavcodec52 libavcodec-extra-53 libavcodec-extra-52
  libavformat53 libavformat52 libavformat-extra-53 libavformat-extra-52
The following NEW packages will be installed:
  libgconf2-4 spotify-client
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
5 not fully installed or removed.
Need to get 0 B/55.1 MB of archives.
After this operation, 130 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Selecting previously unselected package libgconf2-4:amd64.
(Reading database ... 198538 files and directories currently installed.)
Preparing to unpack .../libgconf2-4_3.2.6-0ubuntu2_amd64.deb ...
Unpacking libgconf2-4:amd64 (3.2.6-0ubuntu2) ...
Selecting previously unselected package spotify-client.
Preparing to unpack .../spotify-client_1%3a0.9.11.27.g2b1a638.81-1_amd64.deb ...
Unpacking spotify-client (1:0.9.11.27.g2b1a638.81-1) ...
Setting up libsane:amd64 (1.0.23-3ubuntu3.1) ...
dpkg: error processing package libsane:amd64 (--configure):
 cannot compute MD5 hash for file '/etc/sane.d/v4l.conf.dpkg-new': failed to read (Input/output error)
dpkg: dependency problems prevent configuration of hplip:
 hplip depends on libsane (= 1.0.11-3); however:
  Package libsane:amd64 is not configured yet.

dpkg: error processing package hplip (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of printer-driver-postscript-hp:
 printer-driver-postscript-hp depends on hplip (= 3.14.3-0ubuntu3.2); however:
  Package hplip is not configured yet.

dpkg: error processing package printer-driver-postscript-hp (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of sane-utils:
 sane-utils depends on libsane; however:
  Package libsane:amd64 is not configured yet.

dpkg: error processing package sane-utils (--configure):
 dependency problems - leaving unconfigured
dpkg: dependencyNo apport report written because the error message indicates its a followup error from a previous failure.
                                          No apport report written because the error message indicates its a followup error from a previous failure.
                                                                    No apport report written because MaxReports is reached already
                                                  No apport report written because MaxReports is reached already
                                 problems prevent configuration of simple-scan:
 simple-scan depends on libsane (= 1.0.11-3); however:
  Package libsane:amd64 is not configured yet.

dpkg: error processing package simple-scan (--configure):
 dependency problems - leaving unconfigured
Setting up libgconf2-4:amd64 (3.2.6-0ubuntu2) ...
Setting up spotify-client (1:0.9.11.27.g2b1a638.81-1) ...
Errors were encountered while processing:
 libsane:amd64
 hplip
 printer-driver-postscript-hp
 sane-utils
 simple-scan
E: Sub-process /usr/bin/dpkg returned an error code (1)

after "sudo dpkg --configure -a"

diego@diego-Satellite-C655:~$ sudo dpkg --configure -a
Setting up libsane:amd64 (1.0.23-3ubuntu3.1) ...
dpkg: error processing package libsane:amd64 (--configure):
 cannot compute MD5 hash for file '/etc/sane.d/v4l.conf.dpkg-new': failed to read (Input/output error)
dpkg: dependency problems prevent configuration of simple-scan:
 simple-scan depends on libsane (= 1.0.11-3); however:
  Package libsane:amd64 is not configured yet.

dpkg: error processing package simple-scan (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of hplip:
 hplip depends on libsane (= 1.0.11-3); however:
  Package libsane:amd64 is not configured yet.

dpkg: error processing package hplip (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of sane-utils:
 sane-utils depends on libsane; however:
  Package libsane:amd64 is not configured yet.

dpkg: error processing package sane-utils (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of printer-driver-postscript-hp:
 printer-driver-postscript-hp depends on hplip (= 3.14.3-0ubuntu3.2); however:
  Package hplip is not configured yet.

dpkg: error processing package printer-driver-postscript-hp (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libsane:amd64
 simple-scan
 hplip
 sane-utils
 printer-driver-postscript-hp

Also, there's no available file in my dpkg folder. Could anyone send me his to replace mine?

1 Answer 1

1

It looks like the package libsane is in a weird state, because the package manager looks for a configuration file (*.dpkg-new) that is usually created when the package configuration stage would overwrite an existing and differing configuration file. I recommend that you try to re-install it:

sudo apt-get install --reinstall libsane

or if that doesn't word because of broken packages (which we're trying to fix):

sudo dpkg --remove --pending
sudo apt-get install libsane

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .